Youtube won't connect to youtube

Discussion in 'iPod touch Firmware 3.0' started by BigRob216, Jul 13, 2009.

  1. BigRob216

    BigRob216 New Member

    Joined:
    Jul 13, 2009
    Messages:
    1
    Likes Received:
    0
    Device:
    2G iPod touch
    I have an ipod touch currently running the 3.0 operating system. And it seems to me since the update I have not been able to connect to youtube.

    I have tried all of the trouble shooting tips on the apple website with no luck. I have restored my ipod at least 10 times now.

    It is frustrating because everything else connects to my network just fine. Also, my ipod is not jailbroken, so I don't know what could be causing it.

    On a side note, I have called Best Buy where I bought the ipod and they told me it is the software that needs to be updated.

    I have read on many forums that this issue is from people jailbreaking their ipod, and i find that's ironic because mine is not.

    Does anyone have any suggestions or solutions to my problem?
  2. IPT2GISEPICWIN

    IPT2GISEPICWIN New Member

    Joined:
    Apr 6, 2009
    Messages:
    285
    Likes Received:
    0
    Device:
    iPhone 3GS (Black)
  3. Radish

    Radish Banned

    Joined:
    May 18, 2009
    Messages:
    971
    Likes Received:
    2
    Device:
    iPod touch
    He just said he restored 10 times.

    You should try a DFU restore. Which is restoring it to the factory settings.
  4. wyndwarrior

    wyndwarrior Active Member

    Joined:
    Jun 8, 2009
    Messages:
    1,433
    Likes Received:
    1
    Device:
    3G iPod touch
    Do you live in China?

Share This Page