Xcode Error

Discussion in 'iPod touch Firmware 2.X' started by engineers, Apr 25, 2008.

  1. engineers

    engineers New Member

    Joined:
    Nov 9, 2007
    Messages:
    113
    Likes Received:
    1
    While trying to work my iPod Touch with the iPhone SDK I ran into this error.

    5A240d Problem.jpg (Click Image to make it Larger)
    "Xcode cannot find the software image to install this version"


    I have all of the iPod Touch 2.0 firmware. I was just wondering if there is a certain folder that I can put the ipsw's in so that Xcode can find the software. And no I am not in the iPhone Developer Program.

    Any help would be greatly appreciated.
  2. Teslanaut

    Teslanaut Well-Known Member

    Joined:
    Sep 16, 2007
    Messages:
    15,588
    Likes Received:
    177
    Device:
    4G iPod touch
    You may want to hide your Serial and Identifier. As for that, it means nothing. It just means you never pointed to where the firmware was in Xcode.
  3. engineers

    engineers New Member

    Joined:
    Nov 9, 2007
    Messages:
    113
    Likes Received:
    1
    what do you mean by i never pointed to where the firmware was in Xcode?
  4. Teslanaut

    Teslanaut Well-Known Member

    Joined:
    Sep 16, 2007
    Messages:
    15,588
    Likes Received:
    177
    Device:
    4G iPod touch
    You have to actually select the 2.0 firmware. It recognizes that your device is 2.0. But it doesn't know where the actual firmware is. You installed VIA iTunes yes?
  5. engineers

    engineers New Member

    Joined:
    Nov 9, 2007
    Messages:
    113
    Likes Received:
    1
    Yes. Thanks I got it now. Its sad though Xcode will take pwned firmware!!!

    Also thanks for telling me to to cover my serial. I can't believe I didn't think of that.
  6. LTOUCH

    LTOUCH New Member

    Joined:
    Aug 1, 2008
    Messages:
    1
    Likes Received:
    0
    how do you point the firmware from XCode ?

    sorry but I dont see where and how to tell XCode where the 2.0 firmware is.

    I have the same problem and try to use a second-hand iPodTouch alreday upgrade to 2.0

    thank you in advance for your help.
  7. samarth

    samarth New Member

    Joined:
    Nov 17, 2008
    Messages:
    1
    Likes Received:
    0
    hey can u guys help me with this......i also do have the same problem.....i have an original iphone with firmware version 2.1 and xcode 3.1.1 with iphone sdk version 2.1......

    can u guys give me a detailed description of how to hide the serial no and how to install application on iphone via xcode
    when i use the organizer to install app.....it says "xcode cannot find the software image to install this version"

Share This Page