won't register with itunes

Discussion in 'iPod touch' started by riskyrhythm, Nov 9, 2008.

  1. riskyrhythm

    riskyrhythm New Member

    Joined:
    Nov 9, 2008
    Messages:
    6
    Likes Received:
    0
    Device:
    2G iPod touch
    Hi everybody.

    so i just bought a 16 gig touch. plugged it in to my pc. got a little pic on the ipod of a usb with an arrow pointing to an itunes logo. itunes won't recognize anything begin plugged in tho. tried all my usb ports, but nothing. does it just need to sit and charge for a while before i can even register with itunes?

    thanks in advance
  2. jpga13

    jpga13 Banned

    Joined:
    Dec 4, 2007
    Messages:
    11,591
    Likes Received:
    435
    Device:
    iPad 3
    Do you have iTunes 8? Is it a 2nd gen?
  3. Meikura

    Meikura Super Moderator Staff Member

    Joined:
    Jan 16, 2008
    Messages:
    6,081
    Likes Received:
    431
    Device:
    iPhone 4 (Black)
    It should automatically find it. Is your cable the correct one?
  4. riskyrhythm

    riskyrhythm New Member

    Joined:
    Nov 9, 2008
    Messages:
    6
    Likes Received:
    0
    Device:
    2G iPod touch
    i have itunes 8, its a brand new touch. just bought it today, so i'm assuming its 2nd gen, and the cable is the one that came with it in the box.
  5. cacman93

    cacman93 Banned

    Joined:
    Jul 13, 2008
    Messages:
    1,061
    Likes Received:
    0
    Device:
    iPhone 3G (Black)
    reboot your computer, you have windows, correct?

    Open Itunes?
  6. JohnyW

    JohnyW New Member

    Joined:
    Oct 15, 2008
    Messages:
    570
    Likes Received:
    0
    I had this same problem. Finally had to reinstall iTunes. Give that a try.
  7. Baker5

    Baker5 Well-Known Member

    Joined:
    Jun 26, 2008
    Messages:
    3,230
    Likes Received:
    40
    Device:
    iPhone 5 (White)
    have you installed itunes yet
  8. riskyrhythm

    riskyrhythm New Member

    Joined:
    Nov 9, 2008
    Messages:
    6
    Likes Received:
    0
    Device:
    2G iPod touch
    i uninstalled itunes, re booted, reinstalled itunes. still nothing. running vista.

    thanks

Share This Page