Wifi no longer working

Discussion in 'iPod touch' started by Maki2012, May 10, 2010.

  1. Maki2012

    Maki2012 New Member

    Joined:
    Jun 18, 2009
    Messages:
    31
    Likes Received:
    0
    Device:
    2G iPod touch
    Jailbreak 3.1.2 iPod Touch 2G with redsn0w (latest, don't know x.x.x release number)

    I've always been able to work my own problems out, either by a quick 10 minute max jailbreak and resync or doing some ssh work, but this has given me some problems. I'm not sure what info you would need above the above, so let me know.

    About a day ago, my computer had acted up, not letting me connect to Steam (PC Gaming). Thought it was just PeerBlock (google it, blocks bad IPs from connecting), but it wasn't. Opened up cmd, fiddled around with network settings and looking through ipconfig /all, found nothing wrong. I eventually reinstalled Steam and the problem went away, but I think it is too much of a coincidence that my iPod acted up the same day. I connected to my router and was able to access the internet, but SBSettings game me my WAN IP (73.xxx.xxx.xxx) instead of my LAN IP (192.168.1.x) like it usually does. Now my iPod will connect to networks but there will be no signal bars in the status bar even though Settings and yFy Light (Network Finder App) say I'm connected. I can't ping out of terminal and cannot access any internet whatsoever. Safari gives me an error and even the Weather app says I'm not connected to a network. I have reset all settings in Settings -> General -> Reset -> Reset All Settings and I would hate to have to rejailbreak, so any ideas would be appreciated.

    Thanks
    jmki1
  2. cjschriver3

    cjschriver3 New Member

    Joined:
    Mar 24, 2009
    Messages:
    1,080
    Likes Received:
    0
    Device:
    2G iPod touch
    does your desktop connect to the internet?

    maybe you are connected to the router via the wifi, but the router is not connected to the internet?
  3. Maki2012

    Maki2012 New Member

    Joined:
    Jun 18, 2009
    Messages:
    31
    Likes Received:
    0
    Device:
    2G iPod touch
    I have internet access, and from past attempts I still get wifi bars. It's definitely something wrong with the iPod. I cannot even connect to the router over safari (192.168.1.1). Get the error like I wasn't connected to the internet, even though Settings shows I am connected to the router.

    **See Attached Photos for screenies of the problem**

    jmki1

    Attached Files:

  4. danomac

    danomac Member

    Joined:
    Sep 3, 2008
    Messages:
    62
    Likes Received:
    7
    Device:
    iPhone 4 (Black)
    I am having a similar problem. But mine started immediately after jailbreaking with redsnow, wifi was great one minute and now it ihas been gone ever since I jailbroke. I reset everything even restored the ipod nothing has worked. I was wondering if you got your fixed?
  5. Maki2012

    Maki2012 New Member

    Joined:
    Jun 18, 2009
    Messages:
    31
    Likes Received:
    0
    Device:
    2G iPod touch
    I was able to get it fixed, it requires a full jailbreak. Plug your iDev in to a compter and shift click on the restore button on the iTunes page. If iTunes does not regognize your iDev, power it off and then while holding the home button, plug it into your computer and keep holding the home button. Then do the shift click on restore and find a copy of iPhone firmware 3.1.2. Google it if you do not already have a copy. After a complete restore, use blackra1n from blackra1n.org to rejailbreak. If it says it cannot find <something>.dll, move the executable into (root)://Program Files (x86)/common files/apple/ and then search for the missing dll. If you do not have program files (x86), just use program files.

    Resync, and your problems will be solved.

    I have noticed on occasion that if I shut my iDev down, I can't start it back up without a fresh jailbreak. Apple logo shows up, immediatly dimms, then goes away.

    Good luck!
    jmki1
  6. sleepingman

    sleepingman New Member

    Joined:
    Jun 28, 2009
    Messages:
    9
    Likes Received:
    0
    Device:
    2G iPod touch
    i have the same problem....
    so i just have to do a new jailbreak for everything go back to normal?same ipod model than you, 2gen.

    thanks in advance
  7. daconcerror

    daconcerror Banned

    Joined:
    Sep 6, 2008
    Messages:
    2,898
    Likes Received:
    0
    Device:
    3G iPod touch
    Try hitting 'renew lease' in the wifi networks settings on your ipod
  8. danomac

    danomac Member

    Joined:
    Sep 3, 2008
    Messages:
    62
    Likes Received:
    7
    Device:
    iPhone 4 (Black)
    I just completed a full jailbreak using blackra1n. It did not resolve the issue.
  9. Maki2012

    Maki2012 New Member

    Joined:
    Jun 18, 2009
    Messages:
    31
    Likes Received:
    0
    Device:
    2G iPod touch
    @Danomac
    Do a fresh restore using the iPhone 3.1.2 firmware and do a full sync (minus music and all the extras, just make it usable). Try to connect to the internet then. If you can't, you are screwed. This means there is a hardware problem or you messed something up really bad while having your iDev jailbroken. If you can connect while non-jailbroken, you may have messed up the jailbreaking process. Blackra1n is one of the easiest tools to use, but if its not working for you, use redsn0w, sprint, or any other trusted jailbreaking software. If you cannot connect to the internet from you iDev in any state of jailbreak or non jailbreak, do a complete upgrade (to 3.1.3 or beta 4.0). As far as I know, you can easily downgrade from an itunes downloaded 3.1.3 firmware to a 3.1.2 firmware.

    @Sleepingman
    Yep, follow those instructions and you should be good (unless, as stated above, you could have a hardware defect).

Share This Page