Wi-fi works but it is quite slow

Discussion in 'iPod touch' started by blaine69, Jul 10, 2008.

  1. blaine69

    blaine69 New Member

    Joined:
    May 24, 2008
    Messages:
    3
    Likes Received:
    0
    Here's my problem. I own a 32Gb iPod Touch, my wi-fi connection was working perfectly. But my ISP upgraded my DSL connection (3Mb to 10Mb) and they changed my router.
    In my old router and also in the new one I am using WPA as security measure.
    My internet connection works perfectly in any other computer (almost 8Mb/s average download rates) but my iPod connection, although is connected and it works, it does it in a very slow way, and sometimes especially when watching youtube videos it does not work.
    I've read different posts, also the sticky.
    Here is the testing I've done
    1. I've applied changes to DNS addresses but still the same.
    2. I've changed channels in the router. Still the same.
    3. I've reset iPod and router. Still the same
    4. I've used other wi-fi connection (other router other line), it works perfectly

    Any suggestion??
    Thanks a lot
  2. MoJojojo

    MoJojojo Member

    Joined:
    Jun 25, 2008
    Messages:
    35
    Likes Received:
    0
    Device:
    2G iPod touch
    what kind of router is it?
  3. blaine69

    blaine69 New Member

    Joined:
    May 24, 2008
    Messages:
    3
    Likes Received:
    0
    It is a Zyxel 660HW-D1
  4. blaine69

    blaine69 New Member

    Joined:
    May 24, 2008
    Messages:
    3
    Likes Received:
    0
    I hace upgraded my touch to 2.0, and nothing has changed my wi-fi it is still really slow.
    Any idea!

Share This Page