Why upgrade from 1.1.2 already Jailbroken?

Discussion in 'iPod touch 1.1.4 Jailbreak' started by vitoruch, Apr 29, 2008.

  1. vitoruch

    vitoruch New Member

    Joined:
    Jan 4, 2008
    Messages:
    12
    Likes Received:
    0
    Device:
    iPhone 3GS (Black)
    Folks,

    I'm from out of the U.S., and I have a 1.1.2 jailbreak Ipod touch 8Gb (pre-january version), with several applications mannually installed, including google maps, weather, wiki, etc..and I love it.

    And I see all newer versions, and different kinds of upgrade and jailbreaks...but I'm a little confused:

    Please Register or Log in to view images




    a) Why should I upgrade from a 1.1.2 already Jailbroken? That means - what will I be able to do then, that I cannot do now? I mean, as a standard customer - not developer. Do you strongly recommend it now?

    b) If so, wich is the best - and safer - method to do that?


    Thank you very much!

    Vitor
  2. JonnySK

    JonnySK Active Member

    Joined:
    Apr 20, 2008
    Messages:
    1,767
    Likes Received:
    5
    Device:
    2G iPod touch
    1.1.4 is brilliant because:
    -More stable
    -January update (wiggle apps, web apps, better maps etc)
    -Several easy quick ways to do it

    ways to do it:
    ziphone, iliberty+, pwnage.... take your pic... personally i recommend PWNage if you own a mac, i dont recommend winPWN (yet)

    have a little search around the threads before you make your mind up... make sure you follow instructions when jailbreaking 1.1.4, don't attempt it without help

    hope this helps, PM me for more help
  3. MJeto7

    MJeto7 Member

    Joined:
    Jan 25, 2008
    Messages:
    394
    Likes Received:
    15
    Device:
    iPhone 4S (White)
    i downloaded 1.1.4.
    restored my ipod to 1.1.4
    used ziphone. worked like a charm (DONT FORGET TO CLICK ON JAILBREAK MORE THAN ONCE WHEN YOU USE ZIPHONE!)
  4. gradu

    gradu Banned

    Joined:
    Jan 10, 2008
    Messages:
    355
    Likes Received:
    4
    I jailbroke ma mates
    and presses jailbreak once!
    why twice?
  5. jpga13

    jpga13 Banned

    Joined:
    Dec 4, 2007
    Messages:
    11,591
    Likes Received:
    435
    Device:
    iPad 3
    USe ZiPhone 2.6b or use Pwnage Tool. That multiple touch thing is from months ago! There are several guides available to make it quick and easy.
  6. Khaos

    Khaos Well-Known Member

    Joined:
    Dec 31, 2007
    Messages:
    1,655
    Likes Received:
    127
    Device:
    iPhone 4 (Black)
    i'd like to add on iLiberty +

    I personally thinks its better then ziphone

    so my vote would be:

    Use Pwnage if your mac
    Use iLiberty if your a noob, and own either operating system
  7. Genou55

    Genou55 Member

    Joined:
    Jan 12, 2008
    Messages:
    38
    Likes Received:
    0
    Device:
    iPhone 4S (Black)
    If I jailbreak to 1.1.4 (actually, i'm on 1.1.2), do I will keep all my apps? What's the compatibility with all games and applications? Are they all able to run on 1.1.4?

    Please Register or Log in to view images

    (like iCopter, Garf or BallFight)
  8. Rammi

    Rammi New Member

    Joined:
    Mar 14, 2008
    Messages:
    3
    Likes Received:
    0
    It all depends on the app developer. Obviously, if the developer of the app you use hasn't done anything to their game/app since 1.1.2 was released, then chances are, it won't work on 1.1.4.
    But, you never know... Some do work, and there's this compatibility patch if you want to fool the apps into thinking you're on 1.1.3.
    It's a matter of trial and error, basically.
  9. awal

    awal Well-Known Member

    Joined:
    Jan 2, 2008
    Messages:
    4,764
    Likes Received:
    31
    Device:
    iPhone 4S (White)
    Most apps work on 1.1.4, I've never had any problems. I also recommend iLiberty over Ziphone.

Share This Page