Why not just wait guys?

Discussion in 'iPod touch 1.1.3 Jailbreak' started by padsquad43, Feb 10, 2008.

  1. padsquad43

    padsquad43 New Member

    Joined:
    Dec 25, 2007
    Messages:
    199
    Likes Received:
    0
    Jailbreak for 1.1.3 seems extremely frustrating and many people are so confused and all these applications dont work and yadda yadda. Why don't we just calm down and wait for the SDK so then it won't be so frustrating? The only cool thing it seems for 1.1.3 is the wiggle feature. Do we all really want it that bad?

    This is just my opinion.
  2. Puredudes

    Puredudes New Member

    Joined:
    Dec 26, 2007
    Messages:
    407
    Likes Received:
    0
    Device:
    iPod touch
    Actually its not hard to upgrade as long as u read the instructions, also theres alot of apps that work, and more getting updated daily.
  3. kitren2

    kitren2 New Member

    Joined:
    Nov 12, 2007
    Messages:
    1,383
    Likes Received:
    13
    Device:
    iPod touch
    Idk what your talking about but I'm on 1.1.3 and have all the apps before except mobilechat, which i don't use aim or anything naymore so that doesn't matter.
  4. padsquad43

    padsquad43 New Member

    Joined:
    Dec 25, 2007
    Messages:
    199
    Likes Received:
    0
    +

    and i could never figure it out.
  5. Puredudes

    Puredudes New Member

    Joined:
    Dec 26, 2007
    Messages:
    407
    Likes Received:
    0
    Device:
    iPod touch
    well the google mail, weather, map, stocks, notes the 1.1.3 versions work and its way better. THey got customize to work already i current'y have it on my ipod, appolo never worked for me any way on whatever firmware version i used.
  6. lambson804

    lambson804 New Member

    Joined:
    Dec 3, 2007
    Messages:
    158
    Likes Received:
    2
    That quote's kinda old to reference, don't you think?

    Most of those apps work on the Soft-Upgrade 1.1.3 right now.. Obviously the Maps, Mail, Notes, and Weather for 1.1.2 ARE NOT going to work on your 1.1.3, because you can get the 1.1.3 versions without breaking a sweat.

    Customize works
    Categories works
    Advanced Preferences works
    Poof works
    ...
    What other programs would you like to know that work?


    so yeah, apollo nor mobilechat work correctly, who cares? Just use MEEBO.. it's a better GUI and has better features... plus, if you're using the Soft-1.1.3.. you can just make a webclip of the site.. and now it's just as good as Apollo/MobileChat
  7. kitren2

    kitren2 New Member

    Joined:
    Nov 12, 2007
    Messages:
    1,383
    Likes Received:
    13
    Device:
    iPod touch
    Working:
    Apollo : I dont use.
    MobileChat: I don't use.
    Apple Google Maps 1.1.3
    Apple MobileMail 1.1.3
    Apple Stocks 1.1.3
    Apple Weather 1.1.3
    Customize : Works great.
    advance prefrences : works but don't use.
    poof I dont need I use all my apps.
    Categories : Never found this usefull, I don't have that many apps.
    stackcontroller.app : Don't use, even though it does free up space.
    Location: Just use Google Maps.
  8. Whosthatrandom

    Whosthatrandom New Member

    Joined:
    Jan 16, 2008
    Messages:
    654
    Likes Received:
    4
    Well, after several attempts, my 1.1.3 iPod works perfectly, and all of the apps that I want to use work perfectly. In all honesty, even if everything but MobileScrobbler and a game or two didn't work, I'd still take the time to do it, simply because in the long run it's better to have the latest firmware, especially as 1.1.3 has many advantages, such as being more stable and having the ability to have Movie Rentals (although admittedly the UK iTunes store doesn't have any...), lyrics and an improved Google Maps feature (apart from the locate me feature, the ability to drop a specific placemark and get directions to and from that exact point is very useful indeed).

    I personally am a very patient person, who is willing to tinker with things to work out why they're not working, or how they could work better. Besides, no true jailbreak is perfect either, and the 1.1.3 version will be no exception, and perhaps be more imperfect than it's predecessors; many of the issues that the soft-upgrade 1.1.3 has will apply to the proper jailbreak as well - the main issue is that 1.1.3 doesn't give root privileges to apps by default.
  9. cripesonfriday

    cripesonfriday New Member

    Joined:
    Jan 14, 2008
    Messages:
    210
    Likes Received:
    1
    My 1.1.3 works perfectly, took a bit of patience and trawling through an awful lot of useless sh*te on this forum but everything I want I have.
  10. Puredudes

    Puredudes New Member

    Joined:
    Dec 26, 2007
    Messages:
    407
    Likes Received:
    0
    Device:
    iPod touch
    Technically u guys are still running 1.1.2 but its patched

Share This Page