Why is every1 getting firmware 3.0?!?

Discussion in 'iPod touch Firmware 3.0' started by Waffle2jazz, Jun 26, 2009.

  1. Waffle2jazz

    Waffle2jazz Member

    Joined:
    May 30, 2009
    Messages:
    804
    Likes Received:
    1
    Device:
    4G iPod touch
    Title explains all. Really people, why don't you wait till every cydia app works fine on 3.0 and that there aren't anymore bugs. I'm waiting for sure cause 2.2.1 is great 2 me! couldn't be better and are those few new features worth having your ipod on the line?!? If you look at the forums like 50% of the threads are about 3.0 problems ipod touch AND iphone!!! Please comment about what you think.
  2. voLcoM¯

    voLcoM¯ New Member

    Joined:
    May 21, 2009
    Messages:
    657
    Likes Received:
    0
    Device:
    3G iPod touch
    we all have our opinions. Personally, everything i use already works, so thats y i updated.
  3. mitchell209

    mitchell209 Active Member

    Joined:
    Jan 21, 2009
    Messages:
    8,024
    Likes Received:
    5
    Device:
    iPhone 4 (Black)
    Why wouldn't I upgrade my iPod so I can have longer battery life, faster stuff, less lag, SpotLight, and a ton of other stuff. Most of the main apps that people use are being ported over for 3.0
  4. SumDaii

    SumDaii Active Member

    Joined:
    Nov 17, 2008
    Messages:
    6,297
    Likes Received:
    0
    Device:
    iPod touch
    because most newer better apps are now ocmpatible with 3.0 only.
  5. 42395_skyline

    42395_skyline Community Development Staff Member

    Joined:
    Feb 14, 2009
    Messages:
    10,912
    Likes Received:
    489
    Device:
    iPhone 6
    for me all i need works with 3.0. so thats why i updated. it depends what you like on cydia.
  6. Waffle2jazz

    Waffle2jazz Member

    Joined:
    May 30, 2009
    Messages:
    804
    Likes Received:
    1
    Device:
    4G iPod touch
    I have tons of stuff from cydia that probably wouldn't be ported yet. Also, I've heard lots of issues about bugs and such causing cydia not to work.My opinion is that people should wait until the majority of the apps from cydia are ported over to 3.0 firmware.
  7. David.

    David. Active Member

    Joined:
    Feb 24, 2009
    Messages:
    2,565
    Likes Received:
    1
    Device:
    4G iPod touch
    Maybe because not everyone jailbreaks...
  8. iPhoneFTW

    iPhoneFTW New Member

    Joined:
    Jun 19, 2008
    Messages:
    1,214
    Likes Received:
    0
    Device:
    iPhone 3G (Black)
    If this was a year and half ago I would agree with what your saying but there is such a lack of decent/worthwhile apps for the jailbreak community now days, its not really that much of a big deal that the apps haven't been ported.
  9. Waffle2jazz

    Waffle2jazz Member

    Joined:
    May 30, 2009
    Messages:
    804
    Likes Received:
    1
    Device:
    4G iPod touch
    Ya, i do agree with that.I just won't update yet though cause i still want 2 use the apps i like from cydia that haven't been ported yet. Once a majority of the apps i like from cydia are ported then i'll look into a 3.0 jailbreak for my ipod
  10. SharkSandwich

    SharkSandwich New Member

    Joined:
    Jul 13, 2008
    Messages:
    2
    Likes Received:
    0
    A) Everything I use on 2.2.1 has been ported to 3.0 anyway.
    B) I want the new 3.0 features.
    C) Regardless of whether you want it now or not, you're gonna have to go to 3.0 eventually so why not now? It's only a matter of time before iTunes apps are only compatible with 3.0 and up anyway.

Share This Page