why cant i download the apps =(

Discussion in 'iPod touch Firmware 1.1.3 Discussions' started by glenson, Jan 20, 2008.

  1. glenson

    glenson New Member

    Joined:
    Oct 6, 2007
    Messages:
    2
    Likes Received:
    0
    its there but how do i purchase them =(
  2. eric_chaos

    eric_chaos Well-Known Member

    Joined:
    Nov 4, 2007
    Messages:
    3,746
    Likes Received:
    35
    Device:
    iPhone 4 (Black)
    You need iTunes 7.6 and 1.1.3 firmware.
  3. Steaps

    Steaps New Member

    Joined:
    Oct 24, 2007
    Messages:
    5,074
    Likes Received:
    41
    Device:
    iPod touch

Share This Page