What should my app's "Deployment Target" be?

Discussion in 'iOS Development' started by TechnoEagle, Aug 17, 2010.

  1. TechnoEagle

    TechnoEagle Member

    Joined:
    Jan 2, 2010
    Messages:
    169
    Likes Received:
    0
    Device:
    4G iPod touch
    I am finishing up an iPhone app and was wondering what I should set my iPhone OS Deployment Target to.

    I am using Xcode 3.2.3, and as far as I can tell, the iPhone simulator only supports iOS 3.2 and 4.01. I am pretty sure that my app would work on 3.0 (and maybe even 2.2.1).

    Is there a way to check the app's compatibility with different firmware version?


    Thanks in advance!

    Please Register or Log in to view images

  2. Freerunnering

    Freerunnering Member

    Joined:
    Sep 1, 2009
    Messages:
    296
    Likes Received:
    0
    Device:
    4G iPod touch
    Set development SDK as the minium OS version you want your app to run on.
    So 3.0 is the minium as apple have said apps in the appstore should stop supporting 2.x.
  3. lauNchD

    lauNchD Well-Known Member

    Joined:
    Jan 27, 2008
    Messages:
    1,844
    Likes Received:
    261
    Device:
    iPhone 5 (Black)
    What do you mean by "development SDK"?

    Apple's recommendations:

    Base SDK -> latest software
    iOS Deployment Target -> oldest supported version, e.g. 3.0
  4. Freerunnering

    Freerunnering Member

    Joined:
    Sep 1, 2009
    Messages:
    296
    Likes Received:
    0
    Device:
    4G iPod touch
    Sorry memory/spelling error.

Share This Page