What OS Version?

Discussion in 'iOS Development' started by centroid, Jan 8, 2009.

  1. centroid

    centroid New Member

    Joined:
    Nov 12, 2007
    Messages:
    405
    Likes Received:
    0
    Device:
    iPad 2 (Black)
    To run the sdk can i have 10.5.6?


    Thanks.
  2. Steaps

    Steaps New Member

    Joined:
    Oct 24, 2007
    Messages:
    5,074
    Likes Received:
    41
    Device:
    iPod touch
    10.5.6 will be just fine.

    Please Register or Log in to view images


    If you log onto Apple's developer page (developer.apple.com/iphone) it says:
  3. Nickll9009

    Nickll9009 New Member

    Joined:
    Sep 19, 2007
    Messages:
    1,367
    Likes Received:
    8
    Device:
    iPod touch
    ANY 10.5.X will do =)
  4. centroid

    centroid New Member

    Joined:
    Nov 12, 2007
    Messages:
    405
    Likes Received:
    0
    Device:
    iPad 2 (Black)
    WHAT? you mean 10.5.2 would work also?? like it says on the developer site you must have 10.5.5
  5. Chicken

    Chicken Retired Moderator

    Joined:
    Feb 17, 2008
    Messages:
    2,494
    Likes Received:
    7
    Device:
    iPhone 5S
    Umm I not sure about this but I think that if you had 10.5.2 you would have to find an older version of the SDK which would be hard to find as apple don't host old versions of their SDK's
  6. MrCrawley

    MrCrawley New Member

    Joined:
    Apr 5, 2008
    Messages:
    338
    Likes Received:
    1
    i got it with 10.5.6 but i doubt it would have any problem with 10.5.5
  7. Nickll9009

    Nickll9009 New Member

    Joined:
    Sep 19, 2007
    Messages:
    1,367
    Likes Received:
    8
    Device:
    iPod touch
    All you have to do is edit /System/Library/CoreServices/SystemVersion.plist - Apple is not that smart...
  8. oioioi

    oioioi New Member

    Joined:
    Apr 18, 2008
    Messages:
    102
    Likes Received:
    0
    Whit out the .plist modification you need 10.5.3 or 10.5.4. I got 10.5.4 hackintosh and 2.2 SDK work great
  9. Nickll9009

    Nickll9009 New Member

    Joined:
    Sep 19, 2007
    Messages:
    1,367
    Likes Received:
    8
    Device:
    iPod touch
    Or 10.5.5 or 10.5.6
  10. centroid

    centroid New Member

    Joined:
    Nov 12, 2007
    Messages:
    405
    Likes Received:
    0
    Device:
    iPad 2 (Black)
    oh wow. thanks for that.

    I'm using a hackint0sh for now until i buy my mac but will it work on it? Like what drivers would perhaps be missing?

    Thanks for your help guys! =D

Share This Page