What firmware should i jailbreak on?

Discussion in 'iPod touch Firmware 2.X Jailbreak' started by elvin187, Feb 23, 2009.

  1. elvin187

    elvin187 New Member

    Joined:
    Dec 31, 2007
    Messages:
    3
    Likes Received:
    0
    I currently have 2.2.1 running on my 8gb 1st gen iPod Touch. I was wondering, what's the best firmware to jailbreak on? By best i mean, most customizable, easy, and variety of things to do to it.
    For example, what firmware is it easiest to get themes, games, tweaks, and toys on?

    Also, what's the down-side to the firmware you recommend?

    Thanks Alot.
  2. deleted account 92

    deleted account 92 Active Member

    Joined:
    Jan 1, 2008
    Messages:
    2,797
    Likes Received:
    20
    2.2.1 is the best.
  3. xxhorseriderxxx

    xxhorseriderxxx Banned

    Joined:
    Jan 9, 2008
    Messages:
    544
    Likes Received:
    0
    Device:
    iPod touch
    if ya'z ask me, try out FW 1.1.1, the 12 icon dock is awesome lol
  4. deleted account 92

    deleted account 92 Active Member

    Joined:
    Jan 1, 2008
    Messages:
    2,797
    Likes Received:
    20
    Then you can't have app store. And it has a lot of bugs.
  5. Mac_OS_X

    Mac_OS_X New Member

    Joined:
    Jan 26, 2009
    Messages:
    194
    Likes Received:
    0
    Device:
    3G iPod touch
    Yea just go with 2.2.1 saves u the trouble of downgrading
  6. elvin187

    elvin187 New Member

    Joined:
    Dec 31, 2007
    Messages:
    3
    Likes Received:
    0
    I have 2.2.1 right now but alot of sources don't work in cydia and installer, is that because i have the newest f/w and the sources aren't compatible with it?
  7. ipodtouchesrule

    ipodtouchesrule Active Member

    Joined:
    Jan 5, 2008
    Messages:
    1,009
    Likes Received:
    10
    Device:
    iPhone 4 (Black)
    It all depends on what you want.

    Easiest jailbreak: 1.1.1:

    1. Open Safari.
    2. Go to jailbreakme.com
    3. Go to the bottom and click "Install AppSnap".

    Your done.

    Most customizeable: 1.1.1 or 2.2.1

    Most applications (Games, tweaks, etc.): Again between 1.1.1 or 2.2.1. Leaning more toward 2.2.1.

    It's really up to you. I prefer 2.2.1. Good luck.

Share This Page