well guys i screwd up real bad :P

Discussion in 'iPod touch' started by TheConqueror, May 20, 2008.

  1. TheConqueror

    TheConqueror New Member

    Joined:
    Mar 30, 2008
    Messages:
    1,118
    Likes Received:
    3
    ok so listen, i somehow edited the symlink and now the /applications folder points to /private/var/root folder and i dont know what to direct it to, so all my apps got lost somewhere, so i cant back them up with ibackup, and restoring and putting everything back will take me AT LEAST a week, and i dont have the time. If you save me THANK YOU SO MUCH YOU MADE MY CRAPPY DAY INTO A GOLDEN NIGHT

    If anyone knows how to delete a symlink on winscp or where the applications folder is supposed to direct to, i might be able to fix
  2. merlina

    merlina New Member

    Joined:
    Mar 25, 2008
    Messages:
    10
    Likes Received:
    1
    couldn't you temporarily install terminal.app and then via the ln command create the correct link?
    or maybe if wireless is still on and you installed openssh you could ssh into it?

    just thinking out loud here.

    EDIT:
    Applications folder should just be /Applications
    no symlink, unless you used bosstool to move your apps to have more room.

    these are somewhat the commands bosstool does for you:
    cp -r /Applications /private/var/Applications
    rm -fr /Applications
    ln -s /private/var/Applications /Applications

    BE CAREFULL: using the rm -rf command wrongly could erase everything.

    to use winscp check here: http://winscp.net/eng/docs/task_link
  3. Virtualball

    Virtualball Well-Known Member

    Joined:
    Nov 23, 2007
    Messages:
    1,118
    Likes Received:
    63
    Try ssh'ing into your iPod (if possible) and typing this:

    So, for me, it would be:

    That should fix your problem!

Share This Page