Weird Safari "Bug"

Discussion in 'iPod touch 1.1.4 Jailbreak' started by mikesgroove, Mar 18, 2008.

  1. mikesgroove

    mikesgroove New Member

    Joined:
    Jan 7, 2008
    Messages:
    919
    Likes Received:
    15
    Hey All,

    So I'm encountering kind of a weird issue with safari. I have a 16 g, pre-macworld touch, and I used Ziphone 2.6b for the jailbreak. I've noticed that Safari isn't remembering when I am logged into a site, like ipod touch fans for example. It will keep me logged in for a bit, but as I navigate around it forgets that I'm logged in. Has anyone else experienced this? It's kind of aggravating to have to keep logging constantly. I had to restore and re-jailbreak yesterday, and that's when I noticed this issue. All my safari settings seem correct, and I cleared all caches and cookies to see if that would help. Any tips are appreciated.

    Think I found the solution : http://www.ifans.com/forums/showthread.php?t=33827&highlight=safari+log-in This didn't come up the first time I searched, sorry for the pointless thread.
  2. jshuler

    jshuler New Member

    Joined:
    Sep 27, 2007
    Messages:
    24
    Likes Received:
    0
    Device:
    iPhone 3G (Black)
    Why is this happening with ziphone? Does this happen with an unjailbroken 1.1.4?

    If so, that would mean there is a permissions issue that can only be fixed by jailbreaking

    Please Register or Log in to view images



    If not, what is ziphone changing that breaks Safari's permissions?
  3. mikesgroove

    mikesgroove New Member

    Joined:
    Jan 7, 2008
    Messages:
    919
    Likes Received:
    15
    I don't have the Cookies folder apparently where the .plist with cookies is written. This didn't happen with previous Ziphone JBs for me. I screwed things up with Categories (hate that app) and restored. This time my Safari isn't saving cookies. I guess its something with the way the JB is written on the file system, idk. Pain in the ass though.
  4. prodigee

    prodigee New Member

    Joined:
    Feb 12, 2008
    Messages:
    328
    Likes Received:
    4
    Device:
    iPod touch
    this happened to me as well on 1.1.3 and above. it doesnt matter whether or its ziphone or not i had the problem in 1.1.3 and up and it bugs me a hell of a lot. i wish someone could figure it out and fix it until then you either live with it or go unjailbroken
  5. mikesgroove

    mikesgroove New Member

    Joined:
    Jan 7, 2008
    Messages:
    919
    Likes Received:
    15

    Have you tried the fix from the link I posted? I haven't yet, but plan to try.

    So if anybody else is having this problem, this seemed to work for me-

    In terminal I issued these commands: chmod 777 /var/mobile/Library/Cookies
    chmod 777 /var/mobile/Library/Cookies/Cookies.plist
    and it seems to work. You may only need to issue the last command. Fixing permissions seems to have cleared up the problem.

Share This Page