Water damage to internal speaker?

Discussion in 'iPod touch' started by COniMa, Dec 28, 2009.

  1. COniMa

    COniMa New Member

    Joined:
    Dec 28, 2009
    Messages:
    3
    Likes Received:
    0
    Device:
    3G iPod touch
    Hello,
    I dropped my 3rd generation ipod touch into a bowl of water a couple of weeks age (studip me...). I then put it into a bowl of rice for a week and everything works again except for the internal speaker.
    When I pull my headphones out of my Ipod the volume slider in the music player also dissappeares.
    Is there any way to repair the speaker?
  2. LuffyZoro

    LuffyZoro New Member

    Joined:
    Jun 4, 2009
    Messages:
    224
    Likes Received:
    1
    Device:
    3G iPod touch
    I don't think there is a way for you to repair it, and since it was water damage, Apple won't fix it for you.
  3. COniMa

    COniMa New Member

    Joined:
    Dec 28, 2009
    Messages:
    3
    Likes Received:
    0
    Device:
    3G iPod touch
    hmm.. I thought maybe it was a software problem, because the volume sider doesn't appear when I have no headphones attached.
  4. Magnum

    Magnum New Member

    Joined:
    Nov 27, 2009
    Messages:
    1,264
    Likes Received:
    0
    nah it is probally water damage. now you have a 1gen touch!
  5. jmwerkus

    jmwerkus Active Member

    Joined:
    Apr 9, 2009
    Messages:
    3,030
    Likes Received:
    17
    Device:
    iPhone 5S

    In the form of a 3G!!!
  6. COniMa

    COniMa New Member

    Joined:
    Dec 28, 2009
    Messages:
    3
    Likes Received:
    0
    Device:
    3G iPod touch
    Guess what! My speaker works again!
    I never shut-down my ipod, but I did this yesterday and suddenly it works again.
  7. kingcoolryan

    kingcoolryan Member

    Joined:
    Oct 13, 2009
    Messages:
    627
    Likes Received:
    0
    Device:
    iPad w/ 3G
    Lol sometimes the easyest solution is the hardest to find... I bought something from eBay once and it stopped working... Threw it in my room and a hour later it worked

Share This Page