Warning:Do not update to 2.2 thru Itunes

Discussion in 'iPod touch Firmware 2.X' started by Zombielove, Nov 21, 2008.

  1. Zombielove

    Zombielove New Member

    Joined:
    Oct 22, 2008
    Messages:
    35
    Likes Received:
    0
    Well For some of you it might be to late Please read the lastest blog From the Iphone Dev Team

    Sir, step away from the keyboard.

    So, as anticipated our friends the misfits have recently released the long awaited 2.2 update. We can confirm that this update SHOULD NOT be applied using iTunes if you want the chance of a soft-unlock in the near future.

    If you want to keep that option of a ‘soft-unlock in the near future’ available but you want the new features of 2.2, you will be able to update to 2.2 using a PwnageTool created custom ipsw file that disables the baseband update. You will be able to do this using an updated version of PwnageTool that will be released sometime soon.

    Some facts -
    The 2.2 firmware for 3G contains a baseband update for the 3G iPhone
    The 2.2 firmware for 2G (1st gen iPhones) doesn’t contain a baseband update and the baseband is still at 04.05.04
    We believe that our Pwnage technique (and therefore the Jailbreak) isn’t affected, but PwnageTool and QuickPwn do not support this release as yet, so DO NOT install 2.2 using iTunes as you will lose your jailbreak
    If you apply this update and you previously relied on PwnageTool or QuickPwn to activate your phone, it may become temporarily deactivated and unusable (until we release the new version of PwnageTool or QuickPwn).
    PwnageTool and QuickPwn updates will be released as soon as possible that will allow a safe update path to 2.2. the release of these updates is inevitable but not imminent, we are creating the modifications right now and we need to put the new software through the usual testing process.
    If you apply this update and you have third-party (non AppStore) applications that you rely on they will stop working.
    2G (1st gen) iPhone users who cannot wait for the new PwnageTool or QuickPwn can safely “Update” to 2.2 using iTunes, this will preserve the existing activation. However “restoring” to 2.2 using iTunes will return the iPhone to the unactivated state. If you are in any doubt just wait. NB: This works for 2G ONLY.
    The use of SIM-Proxies (small circuit boards/chips that sit underneath the SIM card) to provide GSM/UMTS service on your locked iPhone 3G is a method that we have always advised against. Early reports suggest that the 2.2 update disables the functionality of these devices. The techniques used were always unreliable and we are surprised that they have lasted this long.
    We are not working on the 2nd generation iPod touch at the moment, so we cannot comment on what the the 2.2 software update may do to this specific model

    So, as always, if you are in any doubt whatsoever please delay the install of this firmware on any of your devices until we have investigated the release in more detail. Watch this space ;-)
  2. Gix1k

    Gix1k New Member

    Joined:
    Aug 20, 2008
    Messages:
    66
    Likes Received:
    0
    What are you telling me here?
  3. Bubalooshi

    Bubalooshi Active Member

    Joined:
    May 22, 2008
    Messages:
    2,432
    Likes Received:
    0
    Device:
    iPhone 3GS (Black)
    So this will only work with the 2G?
  4. dashwood03

    dashwood03 New Member

    Joined:
    Oct 17, 2008
    Messages:
    671
    Likes Received:
    0
    it's already been posted here
  5. Zombielove

    Zombielove New Member

    Joined:
    Oct 22, 2008
    Messages:
    35
    Likes Received:
    0
    That if you have any model other than the ipod touch 2g you will not be able to jailbreak 2.2 if you get 2.2 from itunes beacuse the PwnageToo updates to 2.2.
    ------------------double post merged------------------
    Im sorry dashwood03 I was just in a rush to warn people and didn't bother to use search.
  6. Gix1k

    Gix1k New Member

    Joined:
    Aug 20, 2008
    Messages:
    66
    Likes Received:
    0
    So if you ever want to jailbreak get the software from a source other than iTunes.
  7. ElTres

    ElTres New Member

    Joined:
    Nov 7, 2007
    Messages:
    149
    Likes Received:
    0
    Device:
    iPhone 3GS (Black)
    BS. The warning is about the iPhone, not the iPod Touch! There is no reason not to update a 1st gen iPod Touch, a JB will be available soon.
  8. Zombielove

    Zombielove New Member

    Joined:
    Oct 22, 2008
    Messages:
    35
    Likes Received:
    0
    Sorry ElTres to be honest I didn't read the whole thing....
  9. byroo

    byroo New Member

    Joined:
    Jan 2, 2008
    Messages:
    9
    Likes Received:
    0
    so does this mean that in the future we might have a quickpwn or smth that we can use to update to 2.2 without losing jailbreak?
    im on iphone 3g btw
  10. mikesgroove

    mikesgroove New Member

    Joined:
    Jan 7, 2008
    Messages:
    919
    Likes Received:
    15
    not true. they are referring to future software unlocks, not jailbreaks.

Share This Page