iOS 4.0 Use xcode to downgrade

Discussion in 'iOS Jailbreak & Cydia' started by Milesneptune, Apr 16, 2010.

  1. Milesneptune

    Milesneptune Active Member

    Joined:
    Aug 18, 2008
    Messages:
    1,186
    Likes Received:
    0
    Device:
    iPhone 4 (Black)
    I have my UDID registered and I have the iPhone SDK and xcode. I heard you can downgrade using xcode. how can i do that?
  2. Xii

    Xii New Member

    Joined:
    Sep 9, 2008
    Messages:
    1,147
    Likes Received:
    0
    Device:
    iPhone 4 (Black)
    Same way you upgraded with it. ( I'm assuming you did?)

    Open Xcode go to Window>Organizer. Your iDevice should be listed under there. If it asks you to "Use for Development" just click on it.

    Afterwards just select the firmware version and hit restore.
  3. Milesneptune

    Milesneptune Active Member

    Joined:
    Aug 18, 2008
    Messages:
    1,186
    Likes Received:
    0
    Device:
    iPhone 4 (Black)
    my iphone desont show up
  4. Fieryfear

    Fieryfear New Member

    Joined:
    Apr 4, 2010
    Messages:
    224
    Likes Received:
    0
    Device:
    3G iPod touch
    And my ipod is failing to restore to 3.1.2....
  5. Milesneptune

    Milesneptune Active Member

    Joined:
    Aug 18, 2008
    Messages:
    1,186
    Likes Received:
    0
    Device:
    iPhone 4 (Black)
    i got my iphone to show up but i get an error that my device isnt eligible for the requested build
  6. i.think.different

    i.think.different Banned

    Joined:
    Mar 2, 2010
    Messages:
    943
    Likes Received:
    4
    Device:
    iPhone 4 (Black)
    You CANNOT go back to 3.1.2 with xcode, only 3.1.3. If you have you SHSH's stored on Suarik's server you can tweak your /etc/host file and restore back with iTunes and iRecovery.
  7. Milesneptune

    Milesneptune Active Member

    Joined:
    Aug 18, 2008
    Messages:
    1,186
    Likes Received:
    0
    Device:
    iPhone 4 (Black)
    but heard that you can downgrade to any firmware using xcode because developers need to test their apps
  8. personman

    personman Active Member

    Joined:
    May 1, 2008
    Messages:
    1,466
    Likes Received:
    16
    Device:
    iPhone 5S
    Yeah, there was a thread about it an I can't get my 3rd Gen. iPod Touch back to 3.1.2.
  9. hydropunk

    hydropunk New Member

    Joined:
    Mar 15, 2008
    Messages:
    262
    Likes Received:
    0
    Device:
    iPhone 3GS (Black)
    I tried it, because I was curious about that thread. It doesn't work. It gives the same error that iTunes would give you. At that point, xcode will no longer recognize your device (at least not for me). I also kept getting errors at that point when trying to restore straight back to 4.0 beta, so I had to restore with iTunes back to 3.1.3 and then restore to 4.0 beta again.

    If anyone has information to the contrary, I'd love to hear it, but I don't think it is possible to go back to 3.1.2 with xcode if your device won't do it with other methods posted around this site.

Share This Page