Upgrading to 3.1 worth it?

Discussion in 'iPhone' started by LR2, Feb 13, 2010.

  1. LR2

    LR2 New Member

    Joined:
    Mar 11, 2009
    Messages:
    4
    Likes Received:
    0
    Device:
    iPhone 3GS (White)
    I keep on second guessing myself about this. How many of you decided to stick with 3.0 and don't plan on upgrading? I'm kind of tired to seeing more and more of my apps restricted to the 3.1 firmware.

    Info:
    I have a 3.0 jailbreak with 04.26.08 modem firmware. Cydia has my SHSHs for 3.1 and 3.1.2.

    A few things I have questions about:
    1. If I jailbreak to 3.1.2 will I still be able to tether?
    2. Will I lose the possibility of unlocking? I don't really plan on selling my 3GS anytime soon but if it's unlockable it is more valuable, right?
    3. Is there any way to get 3.1 only apps to run on my 3.0 firmware?
  2. Makaveli96

    Makaveli96 New Member

    Joined:
    Aug 18, 2009
    Messages:
    39
    Likes Received:
    0
    Device:
    2G iPod touch
    I haven't upgraded to 3.1.3 yet.. I still want to keep my jailbreak because I worked so hard on my wallpaper(grr.)..so unless the dev team/geo hotz comes up with a jailbreak, I'm sticking to 3.1.2... btw, to answer your 2nd question, with 3.1.2 you will be able to unlock.. just go to blackra1n.com and download the software and jailbreak/unlock. I don't know about the apps part..
  3. maxam

    maxam Member

    Joined:
    Dec 14, 2009
    Messages:
    371
    Likes Received:
    0
    Device:
    3G iPod touch
    3. I dont think it will work as it is designed for the 3.1 firmware but Im not sure.
  4. DrewGzy

    DrewGzy Active Member

    Joined:
    Dec 11, 2007
    Messages:
    1,205
    Likes Received:
    10
    You're iPhone is kind of a "rarity" being that it is a 3GS with the old iBoot and you kept the 04.26.08 baseband (BTW I have the exact same setup and I am running on T-Mobile).

    Here is my suggestions: definitely keep 04.26.08 simply because you have more options to unlock it. If you have to upgrade you would be OK at 05.11.07 since it is vulnerable with blacksn0w but I would still maintain the old one for now.

    I am running on 3.1.2 and can still tether with it (I just changed my plan and that seemed to change stuff but I have done it before on 3.1.2).

    You mentioned your SHSH's are backed up on Cydia so you are safe there. Use Pwnage Tool to upgrade to 3.1.2; that will keep your old baseband but give you the newer firmware. Definitely stay away from 3.1.3; it will only create more headaches for you.

Share This Page