Upgrading iTouch 1g 2.2 JBroken to 2.2.1

Discussion in 'iPod touch Firmware 2.X' started by Dub_master77, Oct 2, 2009.

  1. Dub_master77

    Dub_master77 New Member

    Joined:
    Oct 2, 2009
    Messages:
    2
    Likes Received:
    0
    Device:
    iPod touch
    Hi,

    I hope someone can give me some advice or tell me of their experiences of doing what I am attempting to do.

    I have a 1st gen iTouch with a hacked 2.2 FW and its Jailbroken using Quickpwn.

    I would now like to upgrade this to Firmware 2.2.1 I have downloaded the new firmware version onto my desktop but before I do anything with it, I would like to draw on your experiences and knowledge just in case I am doing something that will cause me major problems.

    Appologies if this seems like a noob question as that is exactly what I am to this game. Thanks for your time.
  2. Jacob

    Jacob Well-Known Member

    Joined:
    Mar 2, 2009
    Messages:
    4,943
    Likes Received:
    122
    Well, for one I think you should upgrade to 3.0 because thats the latest OS and it is only $4.99. Anyway, to do what you originally want to do here are the steps:

    1. Open iTunes, go to you iPod, and hold shift and press update. Then find the firmware file.

    OR

    1a. If you want to restore (which is a better option in my opinion) then hold shift and press restore instead.

    2. Then download redsn0w 0.8 (link in my signature) and open it.

    3. Follow the instructions to re-jailbreak your iPod. Redsn0w 0.8 also works with 3.0 to jailbreak it.

    I hope that helps.
  3. Dub_master77

    Dub_master77 New Member

    Joined:
    Oct 2, 2009
    Messages:
    2
    Likes Received:
    0
    Device:
    iPod touch
    Hi,

    Thanks for the reply Jawcl. A few questions before I go ahead with the upgrade. Seeing that my itouch has already been jailbroken, upgrading the firmware is 100% possible without it bricking the touch correct ?

    If I get a downloaded O.S. from the net for the itouch, 3.0 or 3.1.1 would this work just as well as the firmware version available from Apple ? The 2.2 that I have seems to work fine and that was downloaded from the net ?

    Thanks...Dub
  4. iptman

    iptman Active Member

    Joined:
    Jun 16, 2009
    Messages:
    1,047
    Likes Received:
    0
    Device:
    2G iPod touch
    1. It won't brick

    2. redsn0w 0.8 works only on 3.0 (NOT 3.1.1)... I don't care where you get it from,,, anything not directly from apple is illegal and may not work...

Share This Page