upgradin to 1.1.1

Discussion in 'iPod touch' started by DJ Xander, Oct 4, 2007.

  1. DJ Xander

    DJ Xander New Member

    Sep 15, 2007
    Likes Received:
    ive tried to upgrade a couple times and always the same result...it gets stuck at preparing iPod for software update.

    then if i take it out its stuck in recovery mode and needs to be restored... i then have to try countlessly on a friends laptop (windows) to restore it with the old version (downloading the new one will take 3 1/2 hours) and then sync my stuff on my mac laptop...

    i want the new update badly but idk whats going on... i cant restore it on my comp i get error 2004 and it stops... any suggestions?

    im gonna pop in the mac os x disc and repair my disk and permissions see if dat helps any
  2. andyandy6464

    andyandy6464 New Member

    Sep 28, 2007
    Likes Received:
    Oh no, problems on a mac? But Mac's ALWAYS work! *snickers*

    Please Register or Log in to view images

    Sorry. Anyway...i dunno. Try seaching for error 2004 on apple's website? I know you can search for error numbers on Microsoft's site
  3. dualcorex

    dualcorex New Member

    Sep 16, 2007
    Likes Received:
    bring it to the apple store and have them do it. just say it doesnt work on your computer for some reason. then if they screw up it is there fault.

Share This Page