Upgrade FW, is it worth it?

Discussion in 'iPod touch' started by gymtonic, Jun 6, 2008.

  1. gymtonic

    gymtonic New Member

    Joined:
    May 27, 2008
    Messages:
    417
    Likes Received:
    0
    Device:
    iPod touch
    Im currently on 1.1.1, happily jailbroken with no problems
    But... I am like 3 firmwares behind the current firmware (4 if you count 2.0 beta), and im thinking about upgrading to 1.1.4. I only want to upgrade for:
    1)Make It Mine
    2)Wiggly Icons
    3)Webclips
    4)The New Dock

    I want to know:
    1) Is it better that 1.1.1?
    2)How long will it take (from restore, jailbreak to sync in iTunes)?
    3)Have you done it?
    4)What is the risk of a "brick"
    5)ziPhone or iLiberty+
  2. jpga13

    jpga13 Banned

    Joined:
    Dec 4, 2007
    Messages:
    11,591
    Likes Received:
    435
    Device:
    iPad 3
    I would wait and see what happens with the 2.0 release. If nothing new comes out or if the newest firmware isn't jailbroken then I would defintely go to 1.1.4.
  3. Joe Rossignol

    Joe Rossignol Community Manager Staff Member

    Joined:
    Jan 9, 2008
    Messages:
    11,500
    Likes Received:
    1,268
    Device:
    iPhone 5 (Black)
    1. Yes, Firmware 1.1.4 is better than Firmware 1.1.1, as it is most recent, more applications are featured on this firmware and many other reasons.
    2. It will vary, although it should take you under 10 minutes.
    3. Yes, I have a jailbroken iPod touch running Firmware 1.1.4.
    4. The risk of a "brick" is slim, you should not worry. One example is using WinPwn to jailbreak, which modifies the bootloader, and you unplug the iPod touch during this process. It could cause the iPod touch to not be able to boot. Don't worry, the methods of iLiberty+ or ZiPhone should be fine.
    5. iLiberty+ is more stable and many users state that they have had little to no problems with iLiberty+. ZiPhone has a conspiracy that it is stolen code, and some users have had to re-jailbreak numerous times using ZiPhone. It's all personal preference.
    Just a few notes:

    • MIM can be run on Firmware 1.1.3 aswell.
    • Wiggly icons, unless you purchased the January App Pack, must be installed through Installer.app along with the 5 January applications (Weather, notes, maps, mail, stocks).
  4. ledhendrixman

    ledhendrixman Member

    Joined:
    Dec 6, 2007
    Messages:
    279
    Likes Received:
    5
    Device:
    iPhone 3GS (White)
    a correction to number 4: your ipod wont brick. it is possible, but not with any of the kailbreak methods out right now.
  5. flattop95

    flattop95 New Member

    Joined:
    Jan 29, 2008
    Messages:
    1,339
    Likes Received:
    11
    Device:
    iPhone 3G (Black)
    i think that you should definitely upgrade to 1.1.4 it is much better
  6. x6blues

    x6blues New Member

    Joined:
    Dec 13, 2007
    Messages:
    2,879
    Likes Received:
    113
    Winpwn and Pwnagetool flash the bootloader so there is that slim chance of a brick but methods like Ziphone/iLiberty+ do not have this possibility.
  7. tian_kr

    tian_kr New Member

    Joined:
    Mar 26, 2008
    Messages:
    935
    Likes Received:
    6
    but the 1.1.1 dock is much sexier
  8. gymtonic

    gymtonic New Member

    Joined:
    May 27, 2008
    Messages:
    417
    Likes Received:
    0
    Device:
    iPod touch
    oh no... the "cheesegrater" dock is much more sexier

    Please Register or Log in to view images



    ill just wait for 2.0 (isn't it been released in a couple of days), then ill wait for a jb (hopefully!)
  9. Bellefire

    Bellefire New Member

    Joined:
    Oct 10, 2007
    Messages:
    44
    Likes Received:
    0
    Definitely upgrade. My friend has the 32gb and I jailbroke it yesterday for her and was shocked to see how many different things there are that require later firmware.

    I'm upgrading right now. I'm specifically doing it for the Hello Kitty theme, but that's irrelevant

    Please Register or Log in to view images

  10. wearmaize

    wearmaize Active Member

    Joined:
    Feb 13, 2008
    Messages:
    2,442
    Likes Received:
    13
    Device:
    iPhone 4S (Black)
    Installer and other apps won't be modified to work on 2.0 for a while.
    Go to 1.1.4, it should take about 10 minutes total depending on some stuff. It's worth it!

Share This Page