Update screwed up my itunes.

Discussion in 'iPod touch Firmware 2.X' started by hockeysk8er2002, Jul 15, 2008.

  1. hockeysk8er2002

    hockeysk8er2002 New Member

    Joined:
    Apr 27, 2008
    Messages:
    8
    Likes Received:
    0
    I updated my touch too 2.0 and downloaded the new itunes. Now when i plug my ipod in itunes becomes unresponsive. Anyone have any ideas or have the same happen to you?
  2. x6blues

    x6blues New Member

    Joined:
    Dec 13, 2007
    Messages:
    2,879
    Likes Received:
    113
    Try a simple uninstall and reinstall. Then post back.

    Also, what OS are you on, Vista, XP, OS X?
  3. moosemun

    moosemun New Member

    Joined:
    Oct 28, 2007
    Messages:
    104
    Likes Received:
    0
    mine does this once in a while too it seems the computer just takes some time....I've had this happen with previous itunes versions also, try waiting a minute or two...
    unless of course it completely frozen

    Please Register or Log in to view images

  4. clarke717

    clarke717 New Member

    Joined:
    Jul 15, 2008
    Messages:
    1
    Likes Received:
    0
    did the same to mine as well....downloaded 2.0 version.......ipod whitscreened.......would not re-install.....fortunately i only had ipod for 3 weeks so i took it back to the shop and got another....I will not be trying to intall 2.0 again......maybe there is a bug or something, i have heard that its not too good with XP??
  5. sdaz

    sdaz New Member

    Joined:
    Jul 10, 2008
    Messages:
    7
    Likes Received:
    0
    it's a bug in 7.7 that causes some touchs/itunes to appear unresponsive. Give it time. I've posted a fix a couple times if you search my user name.
    It may take up to 15 minutes for the ipod to mount and then it usually works fine after that. At least mine did.

Share This Page