Update JB/UL 3G fw 2.2 to 3.0 or 3.1

Discussion in 'iPhone' started by PacMan1, Oct 21, 2009.

  1. PacMan1

    PacMan1 New Member

    Joined:
    Jan 25, 2009
    Messages:
    11
    Likes Received:
    0
    Device:
    iPhone 3G (Black)
    Hello all:

    I am not a tech savy . . . so please help me out in the simplest language.

    I have a 3G 16GB JB and UL with fw 2.28.00 version 2.2 (5G77). How can I upgrade to 3.0 or 3.1 and keep the phone JB and UL still?

    The reason I try to upgrade is because when I go to the App store, I can not download most of the apps because it says 'this application requires the iPhone 2.2.1 software update'. If I can update to this 2.2.1 software, I am just be happy as long as I can continue to keep my iPhone JB/UL.

    Many thanks.
  2. andybno2

    andybno2 New Member

    Joined:
    Mar 25, 2009
    Messages:
    469
    Likes Received:
    0
    Device:
    iPhone 3G (Black)
    personally till they find a way to use the latest baseband with ultrasn0w I would say update to 3.0.1 and use redsn0w as I have found 3.1 does not hold the cellular data network data if the phone is turned off.

    if you do go with 3.0.1 you will need the 3.0.1 ipsw and the 3.0 ipsw file. restore the iPhone to apples stock 3.0.1 official ipsw run redsn0w against the 3.0 ipsw and your set then you just need to install ultrasn0w via cydia and reboot and you have yourself jailbroken and unlocked
  3. DrewGzy

    DrewGzy Active Member

    Joined:
    Dec 11, 2007
    Messages:
    1,205
    Likes Received:
    10
    Like andybno2 mentioned; I'd take it up to 3.0 (at least).

    I would recommend taking it to 3.0 with the factory fimrware. Then update it to a custom firmware to 3.1.2. This will preserve you baseband (allowing you to unlock) and you will also be up-to-date.

    Just don't do anything unless you are certain it is what you want to do; be sure you do not update directly from iTunes.
  4. PacMan1

    PacMan1 New Member

    Joined:
    Jan 25, 2009
    Messages:
    11
    Likes Received:
    0
    Device:
    iPhone 3G (Black)
    Thanks for the tips.

    From what you said, I got a general idea and yes I definitely want to update to a higher firmware version since there are not many apps that is compatible with my current fw.

    How and where do I get the 3.0.1 ipsw and the 3.0 ipsw file? How do you restore to apples stock 3.0.1. I bought my phone already JB/UL and did not do it myself originally. So I have a cluless idea of how to get these redsn0w, ultrasn0w and cydia onto the iphone. Can you send me a tutorial link?

    Thanks
  5. DrewGzy

    DrewGzy Active Member

    Joined:
    Dec 11, 2007
    Messages:
    1,205
    Likes Received:
    10
    You should already have Cydia installed. Also, are you on a Mac or a PC.

    To do the unlock it has to be jailbroken. The JB will add Cydia (or ICY but I think most people prefer Cydia). From there you can download Ultrasn0w which will unlock it.

    I prefer the guides at iClarified.com; They seem to keep up-to-date and everything I have seen is "safe" and there are links for downloading the ISPW's within their guides. iPhone Guides

    From 3.0 you can leave it or take it to 3.1.2 with Pwnage Tool; for now it is only available on a Mac although there is a work around on a PC.

Share This Page