"Unknown Album" comes up with weird artwork? Anyway to rebuild the cache?

Discussion in 'iTunes' started by sdschramm, Jan 4, 2009.

  1. sdschramm

    sdschramm Member

    Joined:
    Jan 27, 2008
    Messages:
    534
    Likes Received:
    0
    Device:
    iPhone 4 (Black)
    I'm having a really weird problem with both the iTunes on my Mac and PC. For example, if I add a new song that does not have the album name listed, it will come up with "unknown album" which is fine. (I will then usually find out what the name is so I can put it in and change the artwork with the actual CD cover)

    Usually, the "unknown album" will come up with a cover with just a music note like this:

    Please Register or Log in to view images



    But for some reason, since iTunes 8 (maybe even 7) came out with the support for iPod and iPhone Apps, now I will get a random APP cover instead of a music note.

    Here is what I am getting:

    Please Register or Log in to view images



    and in clover flow it also comes up as this:

    Please Register or Log in to view images



    But when I go to play the song, the current album art displays:

    Please Register or Log in to view images



    ...and if I drag a real cover in there, it will change. But if I delete the cover (leaving nothing) it goes back to an APP cover instead of the music note.

    Also to note, the App cover will change. Today "CoMag" came up, but tomorrow "SuperMonkeyBall" or "PacMan" may come up?

    Also, if I transfer that song to my iPod touch, the "music note" comes up just as it should, but it does not display it in iTunes.

    I just can figure it out?

    Any ideas?

    Thanks!
    -Scott
  2. buckycat

    buckycat New Member

    Joined:
    Feb 19, 2008
    Messages:
    168
    Likes Received:
    0
    Maybe re-install itunes?
  3. hotwater10

    hotwater10 Banned

    Joined:
    Dec 17, 2007
    Messages:
    1,587
    Likes Received:
    26
    I don't know....I had the same problem. Ronaldo was my artwork for 808's & heartbreak.
  4. redsoxfan11

    redsoxfan11 New Member

    Joined:
    Sep 14, 2008
    Messages:
    74
    Likes Received:
    0
    Device:
    2G iPod touch
    idk if you have already tried this, but go to one of the songs and right click, then get album artwork.
    idk if it will work, but give it a shot
  5. sdschramm

    sdschramm Member

    Joined:
    Jan 27, 2008
    Messages:
    534
    Likes Received:
    0
    Device:
    iPhone 4 (Black)
    nope. tried it.
    Apple doesn't have artwork for the album "unknown album" by "unknown artist"

    I also tried right clicking and choosing "CLEAR album artwork" but that also did nothing.
  6. spykr

    spykr Banned

    Joined:
    Jan 4, 2009
    Messages:
    109
    Likes Received:
    0
    When my Music Library got "corrupted" and I had to use a backup, in Cover Flow all my covers were videos :S.
  7. sdschramm

    sdschramm Member

    Joined:
    Jan 27, 2008
    Messages:
    534
    Likes Received:
    0
    Device:
    iPhone 4 (Black)
  8. saxon.hall.00

    saxon.hall.00 New Member

    Joined:
    Dec 27, 2008
    Messages:
    3
    Likes Received:
    0
    I'm having the same problem, but sometimes, ill get a mix of like two or three album artworks on the one, like its "Tiled" or its just the completely wrong one??
  9. dankbud42o

    dankbud42o New Member

    Joined:
    Mar 12, 2009
    Messages:
    5
    Likes Received:
    0
    mine are completely wrong and tiled too... could be cause of media monkey corrupting it...
  10. sdschramm

    sdschramm Member

    Joined:
    Jan 27, 2008
    Messages:
    534
    Likes Received:
    0
    Device:
    iPhone 4 (Black)
    Good news.....I called Apple Care last weekend and I have a product specialist looking into the issue. She is supposed to call me back this coming weekend with the results.

    I'll post back with anything I find out!

Share This Page