turning off 3g leads to 'no service' - ???

Discussion in 'iPhone' started by cosmos_pete, Sep 9, 2010.

  1. cosmos_pete

    cosmos_pete Member

    Joined:
    Feb 17, 2008
    Messages:
    44
    Likes Received:
    0
    Device:
    iPhone 4 (Black)
    I have an iPhone 4 factory unlocked and un-jaibroken.
    When I have 3G on i have full signal. This is good but i guess having 3G on wastes the battery. So when I turn 3G off the signal goes down and down until it goes to no service.
    Why is this happening? Does this mean I can only use my iphone with 3G enabled? Thats gonna hurt the battery life -.-
    It's on iOS 4.1

    Thanks
  2. omokas

    omokas Member

    Joined:
    Feb 5, 2009
    Messages:
    712
    Likes Received:
    5
    Device:
    iPhone 4 (White)
    Try to restore, if that doesn't work make sure you aren't on a weak signal area. And make sure not to bridge the wifi and gsm antennas

    Please Register or Log in to view images

  3. ZhiZhi778

    ZhiZhi778 Member

    Joined:
    Jan 20, 2008
    Messages:
    936
    Likes Received:
    2
    Device:
    iPhone 3G (Black)
    there might be UMTS (3G) only cells in your reach so no GSM coverage but only UMTS band - usually an UMTS tower covers GSM+EDGE too but they can be seperate too...
    but seems to be a software/hardware prob

    Please Register or Log in to view images

  4. cosmos_pete

    cosmos_pete Member

    Joined:
    Feb 17, 2008
    Messages:
    44
    Likes Received:
    0
    Device:
    iPhone 4 (Black)
    hehe i actually upgraded it to 4.1 today but thing is today was first time using it with my local carrier's sim. cud it be a carrier related problem? And will having 3G enabled use up battery or will it waste battery only if i browse the internet?
    ------------------double post merged------------------
    and i use a case so i cant bridge the antenna's

    Please Register or Log in to view images

    and i have a pretty good signal i have full bars on 3G
  5. Ghetto Toaster

    Ghetto Toaster New Member

    Joined:
    Oct 17, 2008
    Messages:
    297
    Likes Received:
    1
    Device:
    iPhone 4 (Black)
    What carrier are you on? I know that bell and telus in Canada only have 3G towers, no edge/GSM.
  6. link07

    link07 Active Member

    Joined:
    Jun 15, 2010
    Messages:
    1,612
    Likes Received:
    3
    Device:
    4G iPod touch
    ^ ya tell us the carrier you have!

    Please Register or Log in to view images

  7. cosmos_pete

    cosmos_pete Member

    Joined:
    Feb 17, 2008
    Messages:
    44
    Likes Received:
    0
    Device:
    iPhone 4 (Black)
    haha you wouldn't have heard of it i live in Malta but i reckon its only
    3G =/
    It's called "Melita" its really annoying the battery is going down really fast and ive barely used my iphone!

    Please Register or Log in to view images

  8. madmaxmedia

    madmaxmedia New Member

    Joined:
    Oct 19, 2007
    Messages:
    51
    Likes Received:
    0
    You can also try resetting your network settings (Settings- General- Reset- Reset Network Settings), that might do the trick.

Share This Page