Trying to DOWNGRADE from v3.0 to v2.2

Discussion in 'iPod touch Firmware 2.X' started by underwurlde, Jul 2, 2009.

  1. underwurlde

    underwurlde New Member

    Joined:
    Jul 2, 2009
    Messages:
    5
    Likes Received:
    0
    Device:
    iPod touch
    Hello all, hopefully someone can point me to the error of my ways...

    In a nutshell: I am trying to DOWNGRADE from v3.0 firmware to v2.2

    I have a (1 week old) iPod iTouch. It came with v2.2.1 (5H11a) firmware installed on it. I upgraded this to v3.0 and jailbreak it using Redsn0w v0.72.

    All fine and dandy .... BUT...

    I want to put the classic arcade emulator MAME on, and damn it, MAME does NOT work on v3.0 Firmware. Hence I want to downgrade AND then jailbreak a version of firmware that DOES work with MAME.

    I downgraded back to v2.2.1 (5H11a), BUT there is NO damn jailbreak for this for an iTouch. (Correct me if I'm wrong).

    HENCE I need to put in say Firmware v2.2....and THEN I can jailbreak using QuickPWN and then I can get MAME on (and hopefully work). I get hold of this v2.2 firmware and try to downgrade but then get an error in iTunes when attempting to restore to this firmware:

    'The iPod "iPod" cound not be restored becasue the firmware is not compatable"

    Arrrgh!

    Please Register or Log in to view images



    So I then try firmware versions 2.0, 2.01, 2.0.2, 2.1

    Same thing, '.... not compatable'.

    Before I just give up & go back to v3.0 and wait for a version of MAME that IS compatable to be released, can anyone shed any light on what I am doing wrong?

    Thanks in advance,

    Andy

    Q) Is my iTouch a 3G (3rd gen?) iTouch? How would I tell?

    Please Register or Log in to view images

  2. PurpleRa1n

    PurpleRa1n Banned

    Joined:
    Jun 28, 2009
    Messages:
    149
    Likes Received:
    0
    Device:
    iPod touch
    you need to use firmware 2.2.1

    and yeah quickPWN can be used. you just need a copy of quickPWN 2.2.5-2

    pm me if you still have questions
  3. iPhreek

    iPhreek New Member

    Joined:
    Mar 14, 2009
    Messages:
    36
    Likes Received:
    0
    Use QuickFreedom, google for a download link. If you're downgrading, restore to 2.2.1 and jailbreak.

    Get the 2.2.1 firmware from <redacted>
    BTW: There is no iPT3G.
  4. underwurlde

    underwurlde New Member

    Joined:
    Jul 2, 2009
    Messages:
    5
    Likes Received:
    0
    Device:
    iPod touch
    Thanks guys I'll try to find QuickPWN (as I've used that before) and if that's a no-goer I'll then give QuickFreedom a bash.

    Thanks again,

    Andy
  5. studangerous

    studangerous Super Moderator Emeritus Staff Member

    Joined:
    Dec 2, 2007
    Messages:
    5,975
    Likes Received:
    30
    Device:
    iPhone 4 (Black)
    You may also need to downgrade to an earlier version of iTunes... I've also had problems downgrading an iPhone 3G from 3.0 to 2.2.1 fyi... I gave up in the end...
  6. underwurlde

    underwurlde New Member

    Joined:
    Jul 2, 2009
    Messages:
    5
    Likes Received:
    0
    Device:
    iPod touch
    @studangerous: You know, that's exactly what I've been thinking.

    Anyway, results thus far:

    QuickPWN v2.2.5-2: Turns out that was the version I used previously - BUT just in case I downloaded it again & gave it another try: Nope, still no go there.

    As an aside: I'm thinking there are TWO versions of v2.2.1 firmware

    Please Register or Log in to view images

    :
    v2.2.1 (5H11) and v2.2.1 (5H11a)..... This 'a' version is the only one I can downgrade to, I cannot downgrade to the 5H11 verion of v2.2.1

    Subtle I know, anyone shed light on this? I think as studangerous, that the 'a' version is bound to the current version of iTunes

    As for QuickFreedom, again no go. After much time I get a message "unknown error (1603)'. Hmm, not very 'nice' to see & got me a bit twitchy!

    SOOOOO, reverted back to v3.0. Did this fine & dandy. What I did notice is that I got no progress bar during firmware upgrade when using both QuickPWN and QucikFreedom.

    I guess I'm just gunna have to wait for MAME update!

    Please Register or Log in to view images

    THANKS FOR TAKING THE TIME TO HELP ME THOUGH GUYS & GALS!

    Please Register or Log in to view images



    Kind regards,

    Andy
  7. litobro

    litobro Member

    Joined:
    Jul 30, 2008
    Messages:
    162
    Likes Received:
    0
    Device:
    2G iPod touch
    you need the old redsn0w to jailbreak 2.2.1 5h11a which is for the ipod touch 2nd generation. I would recommend checking in that section and also trying redtool.
  8. jfb392

    jfb392 New Member

    Joined:
    Oct 20, 2007
    Messages:
    2,512
    Likes Received:
    21
    Device:
    iPod touch
    You have a 2G.
    5H11a is only for the 2G, so use redsn0w 0.3 to jailbreak it.
  9. Poncho

    Poncho New Member

    Joined:
    Mar 16, 2008
    Messages:
    27
    Likes Received:
    0
    Device:
    iPhone
  10. bluucrayonz

    bluucrayonz New Member

    Joined:
    Jun 30, 2009
    Messages:
    31
    Likes Received:
    0
    Device:
    2G iPod touch
    yeah.. what he said.. but dont you think u should wait? sooner or later someone will make a compatible one, just like the cracked NES 3 for 3.0 FW.

Share This Page