[Tip] Downgrading from 3.0 to 2.x.x

Discussion in 'iPod touch Firmware 3.0' started by cocotutch, Mar 20, 2009.

  1. cocotutch

    cocotutch Community Development Team Staff Member

    Joined:
    Oct 6, 2008
    Messages:
    1,285
    Likes Received:
    117
    Device:
    5G iPod touch
    Holy Motherf*****g Mackerel. Those would be the words to describe what just happened to me.

    Yes, I know now it was stupid to get a 3.0 Gen 1 IPSW from a developer friend and install it myself.....but we all make mistakes.

    Story:

    Copied IPSW from friends External HDD with permission.
    Opened it with iTunes and proceeded to install it onto my 1st Generation iPod Touch.
    Install/Verify Completed.
    3.0 runs on device for 10 minutes, I decide it was too buggy/slow so I try to downgrade from there straight to 2.2.1 within iTunes.

    Error -48 occurs "The iPod "" could not be restored".
    Dang, I try again to no avail.
    So, I open PwnageTool and make a Custom at 2.1.
    Restore to that....

    Error 2 occurs - Endless Reboot Cycle.
    Drat, Drat, Drat and Quadruple Drat.

    Try as I will to get into DFU 8 times, it worked eventually.

    Error -1 occurs "An iPod has been detected, but cannot be identified......"
    ***At this point I was seething and cussing under my breath***

    So, I go through the process listed on Apple Support "Remove iTunes from Mac OS X"

    I re-download iTunes 8.1 and install it.

    Connect iPod Touch in DFU to iTunes........

    Badabing-bada-boom, I get the "This iPod is in Recovery Mode. Restore to use".

    I click Restore.

    My iPod is now working completely, songs, videos and all, I HAVE NOT JAILBROKEN, AND NEVER WILL AGAIN.

    This took over 7 hours to fix, so this is just a guideline for people to fix their iPods if needed, it may not work for 2G.

    cocotutch.
  2. Tman47

    Tman47 Active Member

    Joined:
    Feb 13, 2008
    Messages:
    2,883
    Likes Received:
    20
    Device:
    iPhone 4S (Black)
    I did a dfu restore to 2.2.1, error 1013, then i jailbroke with quickpwn and it booted, then i restored normally to 2.2.1 and it was fine...
  3. bluetiger20

    bluetiger20 New Member

    Joined:
    Sep 16, 2007
    Messages:
    172
    Likes Received:
    1
    Device:
    4G iPod touch
    My DFU restore from 3.0 on a 2G to 2.2.1 was fine, but trying to go from there to jailbreak with Quick Freedom was scary. it took 15 minutes to restore, and then it wouldnt boot from start screen for another 15 minutes. all is fine now.... but yea, it was scary.

    (of note, before i upgraded to 3.0, the jailbreak restore/load process was FAR FAR faster.)
  4. Legendairy

    Legendairy New Member

    Joined:
    Feb 1, 2009
    Messages:
    379
    Likes Received:
    0
    Device:
    2G iPod touch
    I had some problems also, but it turned out to be my pc with iTunes upgraded to v8.1, I just used my hackint0sh and it worked, but 3.0 was buggy so I deleted it.

    Anyone know if you can sync 3.0 on iTunes v8.0.2?

    I also had this problem, but I think it had to do with my iTunes.
  5. cameleon1267

    cameleon1267 Member

    Joined:
    Oct 11, 2007
    Messages:
    494
    Likes Received:
    1
    Device:
    iPhone 4 (Black)
    I could downgrade my ipod touch 1g easily, using DFU mode and restore to stock firmware in itunes, however I had much harder time with my iphone 3G. Looks like my problem was with the DFU mode on my mac 10.5.6.
    I tried on windows 7. restore with stock firmware. I got error 1013. hold power and home for 10 sec then restarted my iphone and voila.

Share This Page