iPhone 3G This is driving me nuts. Trying to unlock an iPhone 3G 2.2

Discussion in 'iPhone' started by RavenII, Feb 17, 2009.

  1. RavenII

    RavenII New Member

    Joined:
    Dec 29, 2008
    Messages:
    61
    Likes Received:
    0
    Ok, I have an iPhone 3G which came to me with 2.0, I updated it to 2.2, I'm trying to follow the guide on iClarified to JB/Unlock it. I made the custom IPSW with 2.2.1, and when I try to restore it I get an error 1600, does anyone know what I could do? or perhaps a link to another tutorial I could follow?

    From what the Dev team blog says, you can't quickpwn it if you wanna do a 2.2.1 with unlock....
  2. loserxprod

    loserxprod New Member

    Joined:
    Dec 4, 2007
    Messages:
    49
    Likes Received:
    0
    From what I'm getting out of that post, you're trying to update to 2.2.1 and unlock it? I think you SHOULDNT do that right now, because then you wouldn't be able to use your phone.

    Why are you making a custom 2.2.1 file when you should be making a custom 2.2 ipsw?

    With the error, it has to do with either you've got a new aluminum macbook that doesn't do DFU mode correctly (please don't get me started on how long it took to ATTEMPT to jailbreak the iphone 2g, along with the 3g), or you're not updating it to the correct ipsw file. I got that error tons of times when I tried to jailbreak my ipod touch 2g and my iphone 3g. Just make sure you're using the right programs and you should be okay.
  3. jimbeam

    jimbeam Active Member

    Joined:
    Nov 19, 2007
    Messages:
    3,694
    Likes Received:
    12
    Device:
    iPhone 3G (Black)
    Is the phone pwned? Also since your using a mac I'm assuming its been updated so you will need to apply a patch to fix DFU compatibility with you mac. Go back to iphone-dev and look for the patch or go to hackint0sh an look for the automatic patcher or just use a USB hub its the safest way.
  4. RavenII

    RavenII New Member

    Joined:
    Dec 29, 2008
    Messages:
    61
    Likes Received:
    0
    The phone is not pwned at all in any way shape or form...It's a completely virgin iPhone 3G, the only thing I did was update it from 2.0 to 2.2. I was under the impression that you're supposed to just make a custom 2.2.1 FW and flash it.

    It's a regular Macbook.
    ------------------double post merged------------------
    anyone???
  5. mattym

    mattym New Member

    Joined:
    Sep 22, 2007
    Messages:
    786
    Likes Received:
    3
    Device:
    iPhone 4 (Black)
    What Jim meant about the macbook patch is that if you are updated to Leopard 10.5.6 then you need to apply a set of patches, otherwise you cannot put the iPhone into the proper mode to jailbreak. Simply search google or these forums. Search for "10.5.6 DFU fix" or something along those lines.
  6. jimbeam

    jimbeam Active Member

    Joined:
    Nov 19, 2007
    Messages:
    3,694
    Likes Received:
    12
    Device:
    iPhone 3G (Black)
    Yes you need a custom 2.2.1 FW, but the iphone will not except it unless it has been pwned. Run pwnage tool again and when it asks "has your iphone been pwnded before does it have the pineapple logo" click NO, then follow the instructions.

    If your Macbook has been updated in the last month or so then you will need the patch so the computer recognizes its in DFU. If you do not want to apply the patch use a USB hub and it will work.

Share This Page