The Ipod drains battery like crazy!

Discussion in 'iPod touch' started by baila, Mar 21, 2008.

  1. baila

    baila New Member

    Joined:
    Mar 21, 2008
    Messages:
    3
    Likes Received:
    0
    Hey guys having a really hard time with my Ipod Touch at the moment.

    The problem consists of:

    When the Ipod is reset or turns it self off and i switch it back on again it will always say 10% battery remaining even if I have just charged it. When I attempt to recharge it from a 100% drained battery it takes like 5 minutes charging before it even realises its charging. The Ipod also feels really warm at the bottom of it when charging.

    It's a very annoying problem and I couldnt put a search on what this problem would be so sorry if its been mentioned before.

    If anyone can help that woud be great.
  2. endrewsmith

    endrewsmith New Member

    Joined:
    Mar 1, 2008
    Messages:
    84
    Likes Received:
    0
    It is normal to have warm back while charging. That's how internal heat dissipate according to apple support.
  3. baila

    baila New Member

    Joined:
    Mar 21, 2008
    Messages:
    3
    Likes Received:
    0
    Cool, I have also noticed that when I go to settings Wi-fi is all in grey and it says no wifi. So I'm guessing something is seriously up with it because I have just done a master reset same problems. Battery goes from 100% to lessthen 10% after a restart.
  4. robcoffee

    robcoffee New Member

    Joined:
    Dec 31, 2007
    Messages:
    335
    Likes Received:
    6
    Sounds pretty normal to be honest, from complete drain it needs that 5 minute initial charge to give the bios (boot loader) power to then instruct the ipod it is charging. And then it will feel hot as the battery charges, but once it is charged it will cool and while plugged in on full charge will be ambient temp.

    If your ipod claims to be at 10% power when you know it should be fully charged I would restore the firmware and re-jailbreak if required.
  5. endrewsmith

    endrewsmith New Member

    Joined:
    Mar 1, 2008
    Messages:
    84
    Likes Received:
    0
    if u are on jailbreak, restore it to orignal firmware just to make sure hardware isn't the one that causing the problem. Jailbreak frimware may not be as stable as original one imo.
  6. baila

    baila New Member

    Joined:
    Mar 21, 2008
    Messages:
    3
    Likes Received:
    0
    I am not using jailbreak and i having the same problem after firmware restore

Share This Page