Term-vt100 error after installing PHP

Discussion in 'iOS Jailbreak & Cydia' started by tigerminx, Nov 27, 2007.

  1. tigerminx

    tigerminx New Member

    Joined:
    Nov 4, 2007
    Messages:
    71
    Likes Received:
    0
    Device:
    iPod touch
    Hi all, if anyone can shed some light on this issue, it would be greatly appreciated.

    After installing PHP, everytime I open Putty or Term-vt100, the first couple of lines throw up the following:

    etc/profile:2: command not found: ^M
    etc/profile:export: 4: not an identifier: PATH^M

    Any ideas? Nothing seems to be broken, but I'm not a big fan of errors

    Please Register or Log in to view images



    Thanks in advance.
    Bruce.
  2. moon ra

    moon ra New Member

    Joined:
    Sep 20, 2007
    Messages:
    80
    Likes Received:
    0
    Sorry tigerminx, I have no answer, just here to say I have the same pb and I need some help too !
  3. moon ra

    moon ra New Member

    Joined:
    Sep 20, 2007
    Messages:
    80
    Likes Received:
    0
    original path ?

    I hope it's related to the original thread :

    Can anybody tell me what path is stated originally in the etc/profile.

    I edited this file and added (or did I replace the path ?) :
    PATH = "/bin:/sbin:/usr/bin:/usr/local/bin:/usr/sbin:/opt/iphone/bin
    But I didn't keep a backup !
    (I was following the steps mentioned here :
    http://www.ifans.com/forums/showthread.php?t=2010
    to set up an apache webserver with PHP 5.2.3)

    Obviously I'm not expert enough, please help!
    (post 78 of this thread : http://www.ifans.com/forums/showthread.php?t=1924&page=8)
  4. tigerminx

    tigerminx New Member

    Joined:
    Nov 4, 2007
    Messages:
    71
    Likes Received:
    0
    Device:
    iPod touch
    I too, never made a backup of the file. But I do know that there mustn't be any spaces between Path and = and " eg.

    PATH="/bin:/sbin:/usr/bin:/usr/local/bin:/usr/sbin:/opt/iphone/bin"

    Bruce.

Share This Page