term-vt 100 now what?

Discussion in 'iPod touch Firmware 1.1.3 Discussions' started by windowsexpert08, Jan 28, 2008.

  1. windowsexpert08

    windowsexpert08 New Member

    Joined:
    Jan 12, 2008
    Messages:
    232
    Likes Received:
    2
    Hey guys i got term-vt100 logged in finally but now how do i change the permission on installer to 755? please help

    thanks
  2. sangesf

    sangesf New Member

    Joined:
    Oct 17, 2007
    Messages:
    355
    Likes Received:
    2
    What did you use as user name and password?

    Still haven't figured it out on mine.
  3. windowsexpert08

    windowsexpert08 New Member

    Joined:
    Jan 12, 2008
    Messages:
    232
    Likes Received:
    2
    Go to installer and add the source www.trejan.com/irepo then find SUID Lib Fix and install that then find Term vt100 SUID Fix and install that and now whenever u restart ipod term vt 100 will work fine with pass as alpine.

    Now if anyone knows how to solve my problem?
  4. johnInSJ

    johnInSJ Member

    Joined:
    Dec 15, 2007
    Messages:
    551
    Likes Received:
    9
    Device:
    iPhone 4 (Black)
    Should not be possible with the dev team jb. Might work with Nate's (since his does horrible, horrible things

    Please Register or Log in to view images

    )

    Term-vt100 uses /etc/passwd, and the touch now uses a different method for multi-user mode login, /etc/passwd has all passwords as * (which means, no terminal login

    Please Register or Log in to view images

    )

    I manually edited my /etc/passwd and pasted in the hash code from my linux box user login, and that worked - setting the password via passwd gets you the infinite springboard crash loop. I am not sure if editing the file does too, so I am not willing to try it again

    Please Register or Log in to view images



    If there is a way to get TERM working with the 1.1.3 dev team jailbreak, I'm all ears!
  5. kappatango

    kappatango New Member

    Joined:
    Jan 2, 2008
    Messages:
    998
    Likes Received:
    6
    In WinSCP:

    Go to menu Commands -> Open Terminal
    In a box next to "Enter command"
    type ( or paste ) chmod 4755 /Applications/Installer.app/Installer
    click execute and that should be it.

    that command is from post 1 on : http://www.ifans.com/forums/showthread.php?t=30601, worked for me
  6. obliviscence

    obliviscence New Member

    Joined:
    Jan 15, 2008
    Messages:
    16
    Likes Received:
    0
    after that can i use 'passwd' command? or not still now?
  7. windowsexpert08

    windowsexpert08 New Member

    Joined:
    Jan 12, 2008
    Messages:
    232
    Likes Received:
    2
    john insj i just told you how to do it on 1.1.3 without manually doing it. and kappatango how do i do it from term vt-100 because i dont have winscp it wont work so i use total commander
  8. johnInSJ

    johnInSJ Member

    Joined:
    Dec 15, 2007
    Messages:
    551
    Likes Received:
    9
    Device:
    iPhone 4 (Black)
    Yeah sorry - I was entering my post - nice find.

    So,
    cd /Applications
    chmod -R 0755 Installer.app

    that should do it
  9. johnInSJ

    johnInSJ Member

    Joined:
    Dec 15, 2007
    Messages:
    551
    Likes Received:
    9
    Device:
    iPhone 4 (Black)
    I would stay away from that for now. The SUID fix worked well though. Too much information to keep track of

    Please Register or Log in to view images

  10. pcoon55

    pcoon55 New Member

    Joined:
    Jan 16, 2008
    Messages:
    32
    Likes Received:
    1
    to change permissions for all applications to executable, try entering:

    chmod -R a+x /Applications/*

    after you enter this, nothing should happen. the # should appear on the next line. if it doesn't work, keep entering it and make sure you have the correct spacing.

    This command comes in handy because I use total commander to add my applications and files, and they only work with the right permissions.

Share This Page