sygic not compatible with itouch 1st gen?!

Discussion in 'iTunes App Store Games & Apps' started by chaseincats, Aug 28, 2009.

  1. chaseincats

    chaseincats New Member

    Joined:
    Dec 1, 2007
    Messages:
    64
    Likes Received:
    0
    I just tried to install Sygic for my 1st gen touch and it told me that it is "not compatible with this ipod"

    is this the case with everybody or do i need to install something before it will let me

    thanks,
    chaseincats
  2. matinsa2005

    matinsa2005 Banned

    Joined:
    Jan 22, 2008
    Messages:
    1,274
    Likes Received:
    0
    Device:
    iPhone 4 (Black)
    may be the graphics are too high for 1st gen i dont know !!!
  3. chaseincats

    chaseincats New Member

    Joined:
    Dec 1, 2007
    Messages:
    64
    Likes Received:
    0
    tomtom works but this doesnt?

    that cant be
  4. matinsa2005

    matinsa2005 Banned

    Joined:
    Jan 22, 2008
    Messages:
    1,274
    Likes Received:
    0
    Device:
    iPhone 4 (Black)
    tom tom doesnt have high quality pictures!!
  5. chaseincats

    chaseincats New Member

    Joined:
    Dec 1, 2007
    Messages:
    64
    Likes Received:
    0
  6. elamre

    elamre Member

    Joined:
    Feb 2, 2009
    Messages:
    551
    Likes Received:
    11
    Device:
    4G iPod touch
  7. chaseincats

    chaseincats New Member

    Joined:
    Dec 1, 2007
    Messages:
    64
    Likes Received:
    0
    boo-urns to that
  8. elamre

    elamre Member

    Joined:
    Feb 2, 2009
    Messages:
    551
    Likes Received:
    11
    Device:
    4G iPod touch
    boo urns? Oo
    what is that supposed to mean?
  9. MikeBoi

    MikeBoi New Member

    Joined:
    Dec 22, 2008
    Messages:
    1,307
    Likes Received:
    0
    Device:
    2G iPod touch
    That means, it's isn't compatible with your iPod.

Share This Page