SummerBoard and Customize [Issues] on 1.1.3

Discussion in 'iPod touch 1.1.3 Application Compatibility' started by DJ Xander, Jan 29, 2008.

  1. DJ Xander

    DJ Xander New Member

    Joined:
    Sep 15, 2007
    Messages:
    832
    Likes Received:
    8
    Here's a spot for everyone to post SUMMERBOARD AND CUSTOMIZE ISSUES for 1.1.3 only!

    How to get SummBoard/Customize to work on 1.1.3:

    1. Once jailbroken entirely, I recommend rebooting.

    2. Go to installer and install MobileFinder and MobileTextEdit

    3. In MobileFinder, go to setting and make sure hidden files and system access are enabled.

    4. Now keep hitting up until you find yourself at "/"

    5. Navigate yourself to "/System/Library/CoreServices/"

    6. Double tap on SystemVersion.plist

    7. At the bottom you will find the text "1.1.3" tap near it and hold (opening the magnifying glass) move it to the right of the "3"

    8. Now delete the "3" and make it a "2"

    9. Press the home button

    10. I recommend rebooting again...

    11. Go to installer and install SummerBoard and Customize and then press the Home Button.

    12. Your springboard will restart and you will end up at the "Slide To Unlock" screen. Slide...

    13. Now go back to installer and install any theme packages for either SummerBoard or Customize and press the home button again.

    14. For safe measures, reboot.

    15. All "should" work well, but it doesn't always.



    *Note* I did not make this tutorial, it was touched upon in several places but I decided that instead of having several converged threads on 1.1.3 issues, one on Customize and SummerBoard alone would benefit many.



    Ok, here is my issue:

    I have a pretty big problem...

    I clean JailBroke 1.1.1 to 1.1.2 to 1.1.3 using the installer method made by the iPod-Elite Team.

    I changed the SystemVersion.plist to make my version 1.1.2 and installed SummerBoard.

    Now here's the problem... No themes appear in SummerBoard!

    When i tap on themes, it just comes up with the background. I know they are there, i SSH'ed into my iPod and made sure the themes I wanted were there.

    I did this to try and correct it:

    1. Rebooted

    2. Deleted SMBprefs.app (/Applications) and the themes folder (/var/root/Library/SummerBoard)

    3. Uninstalled SummerBoard and my themes in installer

    4. Rebooted

    5. Reinstalled SummerBoard in installer

    6. Rebooted

    7. Reinstalled themes in installer

    8. Rebooted

    9. Set permissions to 755 on SMBprefs.app and the themes


    This should fix many issues, but not mine.

    MANUAL FIX for icons:

    1. SSH into iPod

    2. Navigate to /var/root/Library/SummerBoard/Themes

    3. Open the theme you wish to have

    4. Painstakingly move each of the applications icons to their corresponding application and rename them to "icon.png"

    5. Respring

    Note: The only one you cannot change by this method is the Weather icon. To change this here is an untested fix:


    *Credit to Kappatango for above manual icon fix*

    Go ahead and post your issues.

    And for the seasoned user, now is your time to step up and help everyone out!
  2. stabbyjoe12

    stabbyjoe12 Member

    Joined:
    Jan 5, 2008
    Messages:
    972
    Likes Received:
    6
    Device:
    iPad w/ 3G
    same happened to me
    best thign to do is to ssh a working version of summerboard from someone else
    dont ask me im re jailbreak right now

    Please Register or Log in to view images

  3. lol89

    lol89 New Member

    Joined:
    Jan 4, 2008
    Messages:
    76
    Likes Received:
    0
    Device:
    iPod touch
    to fix the themes not showing up just ssh into your ipod and drag the themes from /var/root/library/summerboard i think to /var/mobile/library/summerboard at least that worked for me.
  4. DJ Xander

    DJ Xander New Member

    Joined:
    Sep 15, 2007
    Messages:
    832
    Likes Received:
    8
    i did something of that sort using someones sym guide and the themes still dont work.

    do the themes work now?
  5. lol89

    lol89 New Member

    Joined:
    Jan 4, 2008
    Messages:
    76
    Likes Received:
    0
    Device:
    iPod touch
    they worked for me by just moving them i think it cant just be symlinked but moved. at least i think so
  6. cevanz

    cevanz New Member

    Joined:
    Jan 29, 2008
    Messages:
    30
    Likes Received:
    0
    Where was the warning?

    Maybe I just missed it, but I didn't see any advance warning that my apps and games would be missing after I jailbroke 1.1.3. I followed the YouTube video ipodtouchmaster made. Mine froze during install but after rebooting it appeared fine, all the new iPhone apps worked fine. However, none of my previously installed Apps showed up on the screen. The main ones were Customize, SMBPrefs, and Organizer (new app I noticed recently). So I try installing them again, but they are still installed. So I try uninstalling Organizer but it gives me a "Main Script Error". I SSH in and it appears the apps are still there. I have yet to try this method in the previous post to get all of my apps back.

    It'd be nice (hint hint devs) if there were an app to convert all currently installed apps to 1.1.3 compatibility (at least for the icons on the screen). Heads up to anyone who hasnt done this yet and I hope to hear back. Thanks in advance

    **EDIT**

    Also I noticed when I try editing it thru SSH while having the screen turned off (i.e. in Sleep mode) I keep getting disconnected. Any help?
  7. hockeystar815

    hockeystar815 New Member

    Joined:
    Jan 24, 2008
    Messages:
    75
    Likes Received:
    0
    to get it to stop disconecting you need to set your auto lock settings to never and leave the screen turned on.
    go to settings icon>general>autolocksettings??? >never
    its something like that but as for the error i never got those so sorry
  8. DJ Xander

    DJ Xander New Member

    Joined:
    Sep 15, 2007
    Messages:
    832
    Likes Received:
    8
    hmm ok... i guess the only way to fix this is to clean jailbreak 1.1.1 to 1.1.2 to 1.1.3

    the cleaner the better and now they introduced the GUI format of the jailbreak which may solve your problems
  9. mombopete

    mombopete Member

    Joined:
    Oct 19, 2007
    Messages:
    483
    Likes Received:
    2

    If you read any other threads you would have known all of this.
  10. parak33t

    parak33t New Member

    Joined:
    Dec 8, 2007
    Messages:
    306
    Likes Received:
    4
    Well it's not the actual cuztomize application, but when I was downloading stuff from the installer for customize it rebooted my ipod and put it into recovery mode (sorry can't remember what I was trying to DL, I was pretty mad at that moment)

Share This Page