stuck while restoring "waiting for ipod"

Discussion in 'iPod touch' started by oklaci, Mar 14, 2009.

  1. oklaci

    oklaci New Member

    Mar 14, 2009
    Likes Received:
    I really-really need some expert help here.

    I thethered jailbreaked my ipod touch 2g 2 days ago.
    Today when I wanted to restore it to the original firmware, it got stuck.

    What I did:
    I put the ipod into DFU mode.
    Itunes starts up, I sh+click restore, i choose the original firmware,
    it starts extracting the firmware etc. everything goes fine till the apple logo appears with the loadbar under it. The loadbar progresses very slowly, itunes says it's waiting for ipod, and when the loadbar reaches the end, it stays there for ever, itunes still displaying "waiting for ipod". I waited for half an hour but nothing happened. I checked the itunes log files.
    This is in the last 100 rows and it keeps comeing:

    [timestamp] <Restore device xxxxxxxx>: operation 28 progress: -1

    I tried both firmware versions, bot on windows and on a mac,
    all usb ports.

    I also tried googled around, found a few posts but no relevant fixes.

    Any help would be appreciated.


Share This Page