Strange problem after installing LibUSB

Discussion in 'iPod touch 2G Jailbreak: redsn0w, 24kpwn, etc.' started by Azirad, Mar 6, 2009.

  1. Azirad

    Azirad New Member

    Jan 13, 2009
    Likes Received:
    I recently jailbroke my iPod Touch 2G thanks to jfb392's great tutorial. I have a laptop running Windows Vista and I installed libUSB using compatibility mode (Windows XP SP2). Everything was working fine until today when I restarted my laptop.

    When I plugged in my iPod, my laptop detected an "Unknown Device" and my iPod wouldn't show up. Turns out the unknown device is actually the usb port itself. The port no longer works (tested with my iPod and mouse). The "Unknown Device" driver points to the libusb0.dll in the iRecovery SVN folder. I tried uninstalling it, but it keeps reinstalling as "Unknown Device". I also tried reinstalling libUSB, but that didn't work either.

    Can anyone help me to fix this?

    Just to clarify, my iPod does work, it just the one USB port that doesn't. I have Windows Vista and I correctly installed libUSB. I have other USB ports that do work, but I'd prefer to use the nonworking one due to it's convenient location.

    Any help is greatly appreciated.

Share This Page