Staying on 4.0

Discussion in 'iPod touch' started by It4Ch1, Oct 12, 2010.

  1. It4Ch1

    It4Ch1 Member

    Joined:
    Oct 10, 2010
    Messages:
    151
    Likes Received:
    0
    Device:
    3G iPod touch
    How long should I stay on a Jailbroken 4.0?
  2. applehacker

    applehacker Banned

    Joined:
    Aug 13, 2010
    Messages:
    1,210
    Likes Received:
    0
    Device:
    3G iPod touch
    just upgrade to 4.1.
  3. It4Ch1

    It4Ch1 Member

    Joined:
    Oct 10, 2010
    Messages:
    151
    Likes Received:
    0
    Device:
    3G iPod touch
    Cannot upgrade yet.
    Mine is MC model
  4. applehacker

    applehacker Banned

    Joined:
    Aug 13, 2010
    Messages:
    1,210
    Likes Received:
    0
    Device:
    3G iPod touch
    mine is also mca nd i have upgraded.
  5. Surreallycool

    Surreallycool Member

    Joined:
    Jul 22, 2010
    Messages:
    55
    Likes Received:
    0
    I think its fine to stay..isn't there still people on like 3.13? you can JB your MC model with Limera1n now, I'm personally waiting a bit longer before I do it as I hate waiting for my favorite apps to become compatable with the new updates
  6. HeadReaper

    HeadReaper Well-Known Member

    Joined:
    May 24, 2009
    Messages:
    3,348
    Likes Received:
    679
    Device:
    OnePlus One
    You should stay on 4.0 until greenpoison supports 2GMC models obviously.
  7. Swiss3g

    Swiss3g Member

    Joined:
    May 17, 2010
    Messages:
    479
    Likes Received:
    19
    Device:
    5G iPod touch
    Personally, gamecenter isnt a feature I would upgrade for... Am sticking with 4.0 till 4.2 comes out. AIRPLAY!!!...
  8. It4Ch1

    It4Ch1 Member

    Joined:
    Oct 10, 2010
    Messages:
    151
    Likes Received:
    0
    Device:
    3G iPod touch
    I guess i can stick with 4.0 until there's proper JB for MC
    already made most of theme customization.
  9. Bigray14719

    Bigray14719 Active Member

    Joined:
    Sep 24, 2010
    Messages:
    1,862
    Likes Received:
    0
    Device:
    3G iPod touch
    I'm on 4.0 and I see no reason to move to 4.1

    Gamecenter doesn't really appeal to me.
    Quite a few of the cydia apps aren't compatible with 4.1
    Most of the cydia themes arent setup for 4.1, which means more SSH to correct broken themes.

    I see no point. Sticking on 4.0

Share This Page