SSH not working past /private/var/root ?

Discussion in 'iPod touch' started by Rusty, Apr 24, 2009.

  1. Rusty

    Rusty New Member

    Dec 1, 2007
    Likes Received:
    I've got a problem, and I have no idea how to start it.

    Firstly, I'm running Ubuntu. Don't look away, you don't need any knowledge of Linux to answer this question.

    I've tried using the Connect to Server function, through FileZilla, and through WinSCP with Wine. I know what I'm doing, and it's still not working. It connects to /private/var/root, and just doesn't do anything when I try and change directories.

    The funny thing is, it worked with the ssh function in a terminal. I typed ssh root@192.168.*.***, put in the password, and I used cd /private/var/mobile, and it worked, but graphical applications don't? How is this possible?

    Unfortunately I'm not good enough with the terminal to only use it and nothing else. Save me Batman!

    What could possibly be wrong? iPod touch first gen, firmware 2.2.
  2. mmitt

    mmitt New Member

    Sep 12, 2008
    Likes Received:
    iPod touch
    Check my sig.

Share This Page