iOS 4.0 Spoof Required, I repeat; Spoof Required

Discussion in 'iOS Jailbreak & Cydia' started by iamanipoduser, Jul 7, 2010.

  1. iamanipoduser

    iamanipoduser Member

    Joined:
    Jan 12, 2010
    Messages:
    696
    Likes Received:
    0
    Device:
    iPhone 6 Plus
    Hello everyone,

    I was just wondering if anyone knew if there was an application on Cydia that tricked iTunes into believing that I had an iPod Touch running iOS 4.0, instead of 3.1.2.

    There's this App that I want to get, but, yeah "THIS APPLICATION REQUIRES iOS 4.0"

    Please Register or Log in to view images



    If there is, I'm hoping that it is for free; I'm a simple person

    Please Register or Log in to view images



    Thanks

    Please Register or Log in to view images

  2. The Untouchable iPod

    The Untouchable iPod Member

    Joined:
    Apr 15, 2008
    Messages:
    118
    Likes Received:
    0
    Device:
    iPhone 4 (Black)
    i dont remember where it is but there is a plist file you can edit with to make it say 4.0 and the build version too
    if any one remembers where its at it would be great
  3. Lux2GS

    Lux2GS Well-Known Member

    Joined:
    Jul 1, 2010
    Messages:
    3,678
    Likes Received:
    138
    Device:
    iPhone 4S (Black)
    Go to /System/CoreServices/Springboard.app -> Edit N72AP.plist - Replace 3.1.2 with 4.0 and your build version with: 8A293 - You're Done
  4. Chicken

    Chicken Retired Moderator

    Joined:
    Feb 17, 2008
    Messages:
    2,494
    Likes Received:
    7
    Device:
    iPhone 5S
    The app requires 4.0 for a reason, even if you get it on your device it will most likely crash when you use it.
  5. mitchell209

    mitchell209 Active Member

    Joined:
    Jan 21, 2009
    Messages:
    8,024
    Likes Received:
    5
    Device:
    iPhone 4 (Black)
    I wouldn't even waste your time spoofing your iPod.
  6. iamanipoduser

    iamanipoduser Member

    Joined:
    Jan 12, 2010
    Messages:
    696
    Likes Received:
    0
    Device:
    iPhone 6 Plus
    The App in question is "Broken Sword: The Director's Cut".

    It was perfect just last week, the only criteria it had was OS 3.1 or later or something like that. I didn't download it then, the 2 days later, Revolution release an update, making it only compatible for iOS 4.0.

    I don't think it was a major update though

    Please Register or Log in to view images

  7. studangerous

    studangerous Super Moderator Emeritus Staff Member

    Joined:
    Dec 2, 2007
    Messages:
    5,975
    Likes Received:
    30
    Device:
    iPhone 4 (Black)
    not necessarily...
  8. Stemoy

    Stemoy Active Member

    Joined:
    Dec 23, 2009
    Messages:
    1,075
    Likes Received:
    24
    Device:
    iPhone 5 (Black)
    Are you sure that you're speaking of the right file? the only file on mine that has 3.1.3 on it is the info.plist. Is this what I should change? and could I make it say like 5.0??lol
  9. mgf95

    mgf95 Member

    Joined:
    Jun 29, 2010
    Messages:
    231
    Likes Received:
    0
    Device:
    iPad 3
    why dont you wait like another day or two for ih8sn0w's jailbreak to be released, then you can jailbreak on 4.0
  10. SpeedyApocalypse

    SpeedyApocalypse Member

    Joined:
    Dec 27, 2009
    Messages:
    564
    Likes Received:
    13
    Device:
    4G iPod touch
    All apps submitted to the App Store have to be built for 4.0+. That app may use 4.0 only API's which will cause it to crash or it may not. It is a 50/50 chance if the App crashes.

Share This Page