Som Apps requires OS 3.0 to operate

Discussion in 'iTunes App Store Games & Apps' started by syelloww45, Aug 27, 2009.

  1. syelloww45

    syelloww45 New Member

    Joined:
    Jun 29, 2009
    Messages:
    9
    Likes Received:
    0
    Device:
    2G iPod touch
    Hey guys, there is an app called "Bus x Map Share (Hong Kong)"
    I really need it, my OS is 2.2.1 and it can just operate on OS 3.0 and I can't use it.... if I want to change the data like the version requirement or something other else, can any help me, I don't want to upgrade, what should i do with it??? plz help me... >.<
  2. The_Pirate

    The_Pirate Member

    Joined:
    Aug 15, 2009
    Messages:
    124
    Likes Received:
    0
    Device:
    iPhone 4S (Black)
    u should just upgrade
  3. syelloww45

    syelloww45 New Member

    Joined:
    Jun 29, 2009
    Messages:
    9
    Likes Received:
    0
    Device:
    2G iPod touch
    but i really don't want to upgrade
  4. LssThanThree

    LssThanThree Active Member

    Joined:
    Jan 21, 2009
    Messages:
    1,943
    Likes Received:
    3
    Device:
    iPhone 5 (Black)
    Then you can't use it.
  5. Der-Kleine

    Der-Kleine Active Member

    Joined:
    Jun 24, 2008
    Messages:
    2,314
    Likes Received:
    24
    Device:
    Samsung Galaxy S2
    Apps need Os 3.0 becaus Os 3.0 has features that OS 2.2.1 doesen't have.
    So the features are not there and the app won't work.

    understand that?
  6. Fishy

    Fishy Member

    Joined:
    Feb 17, 2008
    Messages:
    767
    Likes Received:
    22
    Device:
    iPad
    The update is very worth it, you get push, Bluetooth is unlocked and much much more. And you don't lose anything... And you can re-jailbreak. If you got an iPhone it's free and iPod touch of either gen. is 10$
  7. matinsa2005

    matinsa2005 Banned

    Joined:
    Jan 22, 2008
    Messages:
    1,274
    Likes Received:
    0
    Device:
    iPhone 4 (Black)
    im sorry u HAVE TO upgrade!
  8. syelloww45

    syelloww45 New Member

    Joined:
    Jun 29, 2009
    Messages:
    9
    Likes Received:
    0
    Device:
    2G iPod touch
    but, there is a file called Info.plist, can i edit something inside it, so that i can use it as OS 2.2.1 ?
  9. Chicken

    Chicken Retired Moderator

    Joined:
    Feb 17, 2008
    Messages:
    2,494
    Likes Received:
    7
    Device:
    iPhone 5S
    No. The application will crash. 2.2.1 does not have the API's that this application requires.
  10. DotSlashSlash

    DotSlashSlash Active Member

    Joined:
    Feb 29, 2008
    Messages:
    1,134
    Likes Received:
    0
    Device:
    iPhone 3GS (White)
    you can edit the minimumos string but the app will most likely quit because the code in the app is not supported in iphone os's lower than 3.0

Share This Page