slowness from mobilesubstrate

Discussion in 'iPod touch Firmware 2.X Jailbreak' started by jshames, Apr 27, 2009.

  1. jshames

    jshames Member

    Apr 10, 2008
    Likes Received:
    iPad 2 (White)
    OK, I know I'm revisiting an issue that has been discussed in the past, but I want to see if there is any more insight.

    I have jailbroken my 1g ipod touch now for about the 4th time, in order to try to use some of the useful programs, such as clippy, language add-ons etc. I have found this time, as with each time in the past, that it results in an unacceptable lag in starting and running programs. I read studangerous's useful memory guide to analyze the problem. I found that basically when mobile substrate alone is installed, it causes a mild slowdown. Then, with every additional program that uses mobile substrate (without running in the "background"), additional lag occurs. This does not occur when adding app store apps. The only way for me to "neutralize" this lag is to remove mobilesubstrate. I check my memory (RAM) remaining at various times and it doesn't seem to correlate with anything.

    I like using the additional programs, but the performance hit when using the ipod becomes really noticeable and irritating. I use the device as a PDA in addition to being a music player, and having to wait 5 seconds or more after every finger touch for the program to respond--becomes a lousy user experience and interferes with my work. Cydia becomes really slow, taking 30-45 seconds to refesh and become useable. Also mail and contacts become really slow. I DON'T use winterboard, either. (which REALLY slowed things down...), and I only install respected programs, such as SBS settings, etc.

    Now my ipod is still jailbroken but with no programs installed, I'm waiting to see if there are any other ideas.

    Does anybody else notice this, or have any other insights or solutions? Am I the only one who this bothers?

Share This Page