iOS 3.1 Sleep/power button, ringer switch, volume buttons don't respond (iPhone 3G[S])

Discussion in 'iOS Jailbreak & Cydia' started by Bonestack, Mar 9, 2010.

  1. Bonestack

    Bonestack New Member

    Feb 21, 2009
    Likes Received:
    iPhone 3GS (Black)
    Last night I was happily surfing the net with my jailbroken iPhone 3GS on 3.1.2. So, when I then decided to go to sleep I noticed that the sleep button doesn't respond and when I plugged it in to charge it made a loud beeb even when the ringer switch was on mute.

    It dropped from my bed (maybe 30cm high) like 2h before I noted the issue. I have a candyshell case so I doubt that the fall damaged my iPhone. I can't remember any other "accident" that could have done this.

    This morning when I tried to listen to some music (headphones plugged in) the music blasted through the speakers and the volume buttons didn't work. (Would have been nice in class

    Please Register or Log in to view images

    All the buttons feel responsive and click and arent bent or damaged.

    So I tried to reboot my iPhone and delete some cydia apps but nothing has helped. It doesn't reset when I hold home+sleep buttons for 10-15s...
    Does anyone know anything that could cause this problem? Restoring to 3.1.2 would be a pain in the a**...

Share This Page