Should I Upgrade?

Discussion in 'iPod touch' started by hooger, Feb 28, 2008.

  1. hooger

    hooger Banned

    Joined:
    Sep 29, 2007
    Messages:
    419
    Likes Received:
    2
    Well, I'm at firmware 1.1.1 currently and have been since i got my ipod (first windows jailbreak

    Please Register or Log in to view images

    ).

    Ive been following the scene, and am about to restore my ipod. Im restoring it cuz it has been acting sluggish, so i thought since its so easy to do and to rejailbreak i thought i would. So my question is should i stay at 1.1.1 (jailbreaked of course) or should i upgrade to 1.1.2 etc.

    I was thinking of going to 1.1.3, but with all the problems i may just stick with 1.1.1.

    thanks;
  2. Axis

    Axis Super Moderator Staff Member

    Joined:
    Dec 2, 2007
    Messages:
    6,288
    Likes Received:
    133
    Device:
    iPhone 4S (White)
    I say you go to 1.1.2 and stay there for the time being. it's very stable, and it's an actual jailbreak (gotta love that.)

    I'm currently at 1.1.2, and have no problems. I will eventually move on up, but I don't see a need right now.
  3. padsquad43

    padsquad43 New Member

    Joined:
    Dec 25, 2007
    Messages:
    199
    Likes Received:
    0
    1.1.1-easy for jailbreaking
    1.1.2-more stable and smoother
    1.1.3-not a full jailbreak, as mentioned above.
  4. hooger

    hooger Banned

    Joined:
    Sep 29, 2007
    Messages:
    419
    Likes Received:
    2
    Well I guess i'm going with 1.1.2

    Please Register or Log in to view images

    .

    Is this still the latest jailbreak for it? Here
  5. ali.bigolo

    ali.bigolo Member

    Joined:
    Oct 11, 2007
    Messages:
    347
    Likes Received:
    6
    Device:
    iPhone 3G (Black)
    Ziphone should be released by tomorrow so why not just use that, it only takes 3 mins and it's 1.1.4
  6. hooger

    hooger Banned

    Joined:
    Sep 29, 2007
    Messages:
    419
    Likes Received:
    2
    Well I have to say I'm not impressed. After about 3 hours of trying it just wouldn't work. I don't know how many times i tried but everytime, the 1.1.2 jailbreak gave me the error that oktoprep should have been used. which it was.

    I tried downgrading itunes, 3 diff jailbreak 1.1.1 methods, and many different things with no avail, so im at 1.1.1.

    Please Register or Log in to view images

  7. parhom

    parhom New Member

    Joined:
    Feb 28, 2008
    Messages:
    2
    Likes Received:
    0

Share This Page