Should i update ??

Discussion in 'iPod touch Firmware 3.0' started by iFlake, Apr 7, 2009.

  1. iFlake

    iFlake New Member

    Joined:
    Dec 28, 2008
    Messages:
    45
    Likes Received:
    0
    Device:
    iPhone 3G (Black)
    Hi guys, i was wondering should i update my first gen iPod Touch from 2.2 to 3.0 ??? and if you say yes just tell me why...and im going to jailbreak it

    Please Register or Log in to view images

    so if tried jailbreaking the 3.0..does everything work like 2.2 ?
  2. iCrap

    iCrap Active Member

    Joined:
    Jan 4, 2009
    Messages:
    2,639
    Likes Received:
    4
    Device:
    iPhone 4 (Black)
    Obviously you arnt a dev.. so... why..
  3. studangerous

    studangerous Super Moderator Emeritus Staff Member

    Joined:
    Dec 2, 2007
    Messages:
    5,975
    Likes Received:
    30
    Device:
    iPhone 4 (Black)
    ^^^^as he says (welcome back by the way iCrap).

    The 3.0 betas are buggy and are released to devs so they can make sure their apps are compatible with the forthcoming new 3.0 firmware.

    If you are still unsure read this.
  4. iFlake

    iFlake New Member

    Joined:
    Dec 28, 2008
    Messages:
    45
    Likes Received:
    0
    Device:
    iPhone 3G (Black)
    ohhh ok thx

    Please Register or Log in to view images

    Please Register or Log in to view images

    cause my friend knows someone who has it and he told he can update yours if you want soo i came and asked here
    btw thanks for your help again

    Please Register or Log in to view images

  5. John5p

    John5p Member

    Joined:
    Apr 3, 2009
    Messages:
    75
    Likes Received:
    5
    Device:
    Nexus 4

    Please Register or Log in to view images



    im just curious why people would bother upgrading to firmware 3.0 if its only beta. i mean sure it has some nice blutooth features but its just beta. thats why only registered devs can use the beta firmware.
  6. SumDaii

    SumDaii Active Member

    Joined:
    Nov 17, 2008
    Messages:
    6,297
    Likes Received:
    0
    Device:
    iPod touch
    because it's basically like 2.xxxx but with cut,copy n paste...

    spotlight.

    etc.

    Please Register or Log in to view images

  7. Wowfunhappy

    Wowfunhappy New Member

    Joined:
    Dec 29, 2008
    Messages:
    34
    Likes Received:
    0
    Device:
    2G iPod touch
    Because waiting is no fun.

    And because Messing with a cool new firmware (including finding and getting past any bugs) is fun.

    Please Register or Log in to view images



    I don't have 3.0 myself, I'm just pointing out why many non-developers may want the new firmware.
  8. leadergo

    leadergo Active Member

    Joined:
    Aug 2, 2008
    Messages:
    2,384
    Likes Received:
    6
    i already removed the beta1, its not good. unless your a dev, then its handy.
  9. NolesFans

    NolesFans New Member

    Joined:
    Sep 23, 2008
    Messages:
    404
    Likes Received:
    0
    Device:
    iPod touch
    what is a point of waiting if you have applications that doesn't work in 3.0?
  10. gojohnnyboi

    gojohnnyboi Well-Known Member

    Joined:
    Jan 25, 2008
    Messages:
    3,339
    Likes Received:
    55
    Don't update if you're not planning on developing for the 3.0 platform. From a user perspective, it's not worth even considering, which is exactly why it's for developers only. From a developers standpoint, it still has a lot of bugs, but also adds a lot of cool new things to work with.

Share This Page