Should I update to 2.0 now?

Discussion in 'iPod touch Firmware 2.X' started by homers, Jul 12, 2008.

  1. homers

    homers New Member

    Joined:
    Dec 25, 2007
    Messages:
    51
    Likes Received:
    0
    Hi
    I was wondering whether I should update to 2.0 right now. There are a couple of apps that I have that I would like to have on the latest version (VNSea being the main one). When will I be able to jailbreak it?

    I downloaded this: iPod1_1_2.0_5A347_Restore.ipsw
    Is that the latest version?
    Thanks
  2. Axis

    Axis Super Moderator Staff Member

    Joined:
    Dec 2, 2007
    Messages:
    6,288
    Likes Received:
    133
    Device:
    iPhone 4S (White)
    Jailbreaking is one thing, but application compatibility is another. No 1.1.4 apps work on 2.0.

    I like 2.0 non-jailbroken, though I will probably jailbreak in the future.

    You will be able to jailbreak when Pwnage/Winpwn 2.0 comes out.

    What you downloaded is the latest version.

Share This Page