Saurik patches PDF vulnerability for ALL iDevices

Discussion in 'Latest Tech News and Rumors' started by Ezekeel, Aug 12, 2010.

  1. Ezekeel

    Ezekeel New Member

    Joined:
    Mar 15, 2009
    Messages:
    771
    Likes Received:
    0
    Device:
    iPhone 3GS (Black)
    Saurik released a patch to close the PDF vulnerability which is used by jailbreakme.com and could be (and probably will be) used for malicious code in the future. This patch is supposed to work for all iDevices on all firmwares, so no need to update to 4.02. You can find it on Cydia as "PDF Patch".

    Source: http://blog.iphone-dev.org/post/941467261/fixing-what-apple-wont
  2. ipNinja

    ipNinja New Member

    Joined:
    Mar 5, 2008
    Messages:
    1,209
    Likes Received:
    5
    Device:
    iPhone 3GS (White)
    This is old news and im pretty sure it wasn't Jay Freeman who created it? Maybe wrong though

    Ignore all of the above, your link proves me utterly wrong !

    Please Register or Log in to view images

  3. The Killswitch

    The Killswitch Well-Known Member

    Joined:
    Mar 11, 2009
    Messages:
    1,614
    Likes Received:
    117
    Device:
    Samsung Galaxy S4
    Gee, thanks Apple. I'm glad to know I still matter to you as a customer, even though my device is old.

    Another reason this company annoys me.
  4. Badd_Blood

    Badd_Blood Well-Known Member

    Joined:
    Aug 1, 2010
    Messages:
    10,542
    Likes Received:
    1,686
    Saurik was posting on twitter yesterday that he was working on this.

    It's sad that people think the jailbreaking community is bad and yet they are helping people more then Apple is helping their own customers.
  5. AgedBike

    AgedBike New Member

    Joined:
    Apr 6, 2010
    Messages:
    155
    Likes Received:
    0
    Device:
    3G iPod touch
    Apple really should have made a patch for the older devices, but they didn't, so this is good news.
  6. Zedoack

    Zedoack Member

    Joined:
    Apr 29, 2010
    Messages:
    246
    Likes Received:
    0
    Device:
    iPhone 4 (Black)
    Installed.

    Please Register or Log in to view images


    I'm surprised apple never made any 3.1.4 firmware for the older, 1st gen devices to patch this.

    Please Register or Log in to view images

  7. jimbeam

    jimbeam Active Member

    Joined:
    Nov 19, 2007
    Messages:
    3,694
    Likes Received:
    12
    Device:
    iPhone 3G (Black)
    You haven't re-upped on any give-a-sh*t from Apple lately. Your old money doesn't matter anymore, give-a-sh*t is a new money privilege only. This is how Apple works, most companies really.
  8. zombie boy99

    zombie boy99 Well-Known Member

    Joined:
    Aug 11, 2010
    Messages:
    7,730
    Likes Received:
    276
    Device:
    iPhone 5S
    Do I need to get the PFD Patch in Cydia if I didn't Jailbreak with JailbreakMe.com?
  9. Zedoack

    Zedoack Member

    Joined:
    Apr 29, 2010
    Messages:
    246
    Likes Received:
    0
    Device:
    iPhone 4 (Black)
    I'd recommend you do. The exploit is there regardless, thus having the potential to load malicious code.

    Please Register or Log in to view images

  10. zombie boy99

    zombie boy99 Well-Known Member

    Joined:
    Aug 11, 2010
    Messages:
    7,730
    Likes Received:
    276
    Device:
    iPhone 5S

Share This Page