Ruby & Mobile Substrate, anyone?

Discussion in 'iPod touch' started by dumbnameiknow, Jan 10, 2009.

  1. dumbnameiknow

    dumbnameiknow New Member

    Joined:
    Sep 14, 2008
    Messages:
    21
    Likes Received:
    0
    I'm trying to get 5 column Springboard up. But, I can't seem to find Ruby or Mobile Substrate, despite having all the inherited repos. I haven't heard of any firmware specifics for running the 5Col Springboard, anyone got any ideas for me? Thanks a lot.
  2. NeSEncHo

    NeSEncHo Active Member

    Joined:
    Jul 16, 2008
    Messages:
    1,322
    Likes Received:
    0
    MobileSubstrate is already installed. I couldn't find Ruby on Cydia either and I have no filters enabled, so I went into Mobile Terminal and ran "apt-get install Ruby".
  3. dumbnameiknow

    dumbnameiknow New Member

    Joined:
    Sep 14, 2008
    Messages:
    21
    Likes Received:
    0
    Hey thanks a lot! But... i have another problem... my Terminal doesnt work, and i cant find the problem, haha. it says bin/rm remove the write protected file, and i dont know what it means.
  4. iMario

    iMario Well-Known Member

    Joined:
    May 11, 2008
    Messages:
    1,642
    Likes Received:
    153
    Device:
    iPhone 5S
    Go to Manage -> hit Settings (top left). then change to hacker or something..
  5. Sarcasm Siempre

    Sarcasm Siempre New Member

    Joined:
    May 9, 2008
    Messages:
    1,836
    Likes Received:
    0
    Device:
    iPod touch
    Just run a Cydia search for "Ruby", it'll show up.
  6. mogey16816

    mogey16816 New Member

    Joined:
    Aug 2, 2008
    Messages:
    152
    Likes Received:
    0
    Device:
    iPod touch
    I found ruby no problem. Just search it.
  7. buckycat

    buckycat New Member

    Joined:
    Feb 19, 2008
    Messages:
    168
    Likes Received:
    0
    Ruby should be on Cydia, and Mobile Substrate is already installed. I have a five column springboard on firmware 2.2 working perfectly.
  8. dumbnameiknow

    dumbnameiknow New Member

    Joined:
    Sep 14, 2008
    Messages:
    21
    Likes Received:
    0
    haha trust me... Ruby isnt there. No filters or anything. about the SSH route... any word?
  9. NeSEncHo

    NeSEncHo Active Member

    Joined:
    Jul 16, 2008
    Messages:
    1,322
    Likes Received:
    0
    You have OpenSSH installed? If so, ssh (not with a file browser like WinSCP. Use a text one like Terminal or PuTTY) into your iPod as root and run "apt-get install Ruby" which should install it.
  10. dumbnameiknow

    dumbnameiknow New Member

    Joined:
    Sep 14, 2008
    Messages:
    21
    Likes Received:
    0
    Haha! nothing seems to give. typed in the root command, then typed in apt-get command and it says "couldnt find package Ruby". should i mention my 2.1 firmware?

Share This Page