Restore problems

Discussion in 'iPod touch' started by Twinklezz, Dec 27, 2008.

  1. Twinklezz

    Twinklezz New Member

    Joined:
    Dec 27, 2008
    Messages:
    1
    Likes Received:
    0
    ok... i got an ipod touch first gen for christmas. I was updating to 2.2 and it asked for me to backup and i did. Then it started to restore my ipod and said error 1603 after a few minutes. I even went back to the store and they fixed it. (Does anyone know how they restore it cause i want to get mine back to factory default.) I only had photos on it so nothing much and when i got back home i tried to re update it and the same thing happened. Apple did not help at all and i have to make ANOTHER reservation to go back 40 minutes away AGAIN. someone please help me cause i would like to enjoy my christmas present. thank you
    ------------------double post merged------------------
    I was able to restore it to factory on another computer. I downloaded all my songs and stuff but the update just isn't working. HELP please

Share This Page