iOS 4.0 Restore Non-Dev 4.0 to 3.1.2?

Discussion in 'iOS Jailbreak & Cydia' started by TheSedge, Apr 8, 2010.

  1. TheSedge

    TheSedge New Member

    Joined:
    Sep 4, 2008
    Messages:
    18
    Likes Received:
    0
    Device:
    iPhone 3GS (Black)
    I got the 4.0 Beta from my friend, who is a developer, and he said it should work on my 3GS. I restored using the 4.0 Restore, and everything worked perfectly, but then it said 'We're unable to complete your activation. This device is not registered as part of the iPhone Development Program." Now it's stuck. There is no "Restore" option, just the activation message.

    Don't flame me, I understand that I have failed, but i just need help.

    Can I restore back to 3.1.2?

    Also, is it possible to somehow register my iPhone to the Dev Program? I know you have to pay $100 (which is fine), but is there an alternative?

    Thanks for any help.
  2. Tkf1

    Tkf1 Community Development Staff Member

    Joined:
    Oct 12, 2009
    Messages:
    17,397
    Likes Received:
    2,488
    Device:
    iPad mini
    Did you backup your 3.1.2 SHSHs? Then just do a DFU restore.

    You only need to pay that $100 if you want to submit an app to the app store.
  3. tanktan38

    tanktan38 Active Member

    Joined:
    Dec 29, 2009
    Messages:
    1,085
    Likes Received:
    15
    Device:
    3G iPod touch
    You're making it sound like if you haven't paid $100, you can download the 4.0 beta. I wish, but I don't think so.
  4. Tkf1

    Tkf1 Community Development Staff Member

    Joined:
    Oct 12, 2009
    Messages:
    17,397
    Likes Received:
    2,488
    Device:
    iPad mini
    I have a Dev account or atleast I think I do. And I didn't play no 100$ fee. I think only Devs who payed the fee can download 4.0.
  5. mitchell209

    mitchell209 Active Member

    Joined:
    Jan 21, 2009
    Messages:
    8,024
    Likes Received:
    5
    Device:
    iPhone 4 (Black)
    Why didn't you have your friend register your UDID? if he had done that, it would have worked fine.
  6. TheSedge

    TheSedge New Member

    Joined:
    Sep 4, 2008
    Messages:
    18
    Likes Received:
    0
    Device:
    iPhone 3GS (Black)
    DFU Restore

    I tried the DFU Restore to 3.1.2 but it didn't work (Error 1015) so I think i have to get 3.1.3. There goes my jailbreak....oh well I guess I can sign up with my mates as a Company, that'll work.
    ------------------double post merged------------------
    Alright, I downloaded 3.1.3, but since I downgraded from 4.0, it still has the error! By the looks of things, I'm pretty much screwed until 4.0 is released to the public...surely there's another way?
  7. dunuck

    dunuck Active Member

    Joined:
    Jul 20, 2009
    Messages:
    3,070
    Likes Received:
    1
    Device:
    2G iPod touch
    put your iphone in dfu mode, and downgrade to 3.1.3
  8. superrob

    superrob Member

    Joined:
    Dec 9, 2008
    Messages:
    580
    Likes Received:
    1
    Device:
    iPhone 4S (Black)
    Ahh i just read about this before going for 4.0 myself (im a dev), 1015 should be that the restore was a success but that it cannot be use because of the small change in the baseband. Just restore to 3.1.2 and if you get error 1015 then simply cannot your iphone in restore mode (hold home while pluging in your iPhone whle its powered off), and then simply jailbreak using for example RedSnow

Share This Page