Restore issue - iTouch 2g

Discussion in 'iPod touch' started by ryanray, Jun 4, 2009.

  1. ryanray

    ryanray New Member

    Joined:
    Jun 4, 2009
    Messages:
    1
    Likes Received:
    0
    Hello.

    I recently restarted my iPod completely from it's settings menu. After doing that it seems to be stuck in DFU mode.
    I tried hooking it up to iTunes and after doing the button holding routine it detects the iPod and says it should be restored.

    I didn't want to do that, so I figured I would try and boot it like the redsn0w tethered jailbreak guide through the command prompt with all the jailbreak files.
    Sure enough, following through it I get a error in the command prompt saying "The system cannot execute the specified program." when I type in irecovery -f ibss211.dfu.

    Then I tried just restoring it through iTunes, but sure enough iTunes gives me a error saying "Software for this iPod is currently not available. Make sure you have the latest version of iTunes and try again."

    What can I do to get my iPod back up and running?
    If anything I just want to restore my iPod completely through iTunes.


    EDIT- Solved it myself.

    For future reference:

    Download your ipod's firmware to your desktop.
    Go into itunes and shift click "restore."
    A menu will pop up, just click your firmware. There you go~!

Share This Page