Restore failing with uknown error 20, trying to change name

Discussion in 'iPod touch' started by ColKurtz, Dec 11, 2009.

  1. ColKurtz

    ColKurtz New Member

    Joined:
    Dec 1, 2009
    Messages:
    7
    Likes Received:
    0
    Device:
    3G iPod touch
    Hi. I purchased an iPod Touch 8G 3G, which I returned after learning the tethering limitations and lack of HW upgrades. I got a refurbished 16GB 2nd Gen instead, which came with 2.2 FW. I updated to 3.12 firmware, then jailbroke. All of this went fine.

    I attempted to restore to factory defaults (this is a gift so will have to start over on his computer eventually) and got "unkown error occurred (20)". I tried shift-restore and pointed it to a local version of the Gen2 3.12 ipsw file. Same error.

    For a while I thought it was bricked but in an attempt to put it into DFU mode (would there be any need?) it came back up, still jailbroken.

    I'm paranoid to try another restore attempt until I know what might be going on. Is there something about going from 2.2 to 3.12 and then restoring to factory defaults? Does it want me to restore to 2.2... I didn't think you could downgrade from 3.12 WHen I tried to restore it said "contacting apple" before attempting the restore... it was jailbroken at the time.

    Thanks for any ideas/info.
  2. Jacob

    Jacob Well-Known Member

    Joined:
    Mar 2, 2009
    Messages:
    4,943
    Likes Received:
    122
    Just press restore. Then it will ask you if you want to "Restore and Update" and click that button, it will download the firmware then you're done.

Share This Page